Categories

Regaining debug access of NXP i.MX RT1064-EVK executing WFI

Posted on Thursday, January 3rd, 2019 in ARM, tutorials by DP

i.MX-RT1064-EVK-Boar

Erich Styger writes:

Working with low power modes can be challenging. It can severely affect debugging capabilities of a microprocessor or microcontroller. I ported a FreeRTOS application using the Tickless Idle Mode to the NXP i.MX RT1064 board, and all of a sudden, the board was unresponsive to any debugger connection. Luckily the board was not really bricked, but it took me while to find a way to recover it. So for when you end up in a situation with a ‘bricked’ i.MX RT1064 board, this article might be helpful for you to recover it.

More details on MCU on Eclipse blog.

This entry was posted on Thursday, January 3rd, 2019 at 3:02 pm and is filed under ARM, tutorials. You can follow any responses to this entry through the RSS 2.0 feed. You can skip to the end and leave a response. Pinging is currently not allowed.

Leave a Reply

Notify me of followup comments via e-mail. You can also subscribe without commenting.

Recent Comments

  • gant: They still have a couple of the more expensive (but still considerably cheap) 5S-I-S01 in stock...
  • readybrek: Anyone got a any recommendations for a budget-priced hot air station?
  • William: lol I'm happy to waste 3c for each program/debug cycle... but probably not the time spent soldering a new device down to a proto board!...
  • Joe Desbonnet: Ya, I can recommend the low melting point solder. I used brand 'ChipQuik' and it's amazingly easy to use.
  • Jerome: I need a new BusPirate for the Fablab ;) Many thanks!