Categories

Regaining debug access of NXP i.MX RT1064-EVK executing WFI

Posted on Thursday, January 3rd, 2019 in ARM, tutorials by DP

i.MX-RT1064-EVK-Boar

Erich Styger writes:

Working with low power modes can be challenging. It can severely affect debugging capabilities of a microprocessor or microcontroller. I ported a FreeRTOS application using the Tickless Idle Mode to the NXP i.MX RT1064 board, and all of a sudden, the board was unresponsive to any debugger connection. Luckily the board was not really bricked, but it took me while to find a way to recover it. So for when you end up in a situation with a ‘bricked’ i.MX RT1064 board, this article might be helpful for you to recover it.

More details on MCU on Eclipse blog.

This entry was posted on Thursday, January 3rd, 2019 at 3:02 pm and is filed under ARM, tutorials. You can follow any responses to this entry through the RSS 2.0 feed. You can skip to the end and leave a response. Pinging is currently not allowed.

Leave a Reply

Notify me of followup comments via e-mail. You can also subscribe without commenting.

Recent Comments

  • ConnyCola: When will the page go online? I would love to see more of the new service!
  • Edward Mallon: Dr. Beddow's instrumentation class has been building the 2016 version of the Cave Pearl datalogger for more than three years, and feedback from that experience...
  • Neal: Loose no more.
  • Crawford: Must try to win...
  • readybrek: If you like a lot of chocolate on your biscuit join our club!