Skip to main content
Topic: BP v4.0c USB no recognize device - signed drivers for w8 64b (Read 2456 times) previous topic - next topic

BP v4.0c USB no recognize device - signed drivers for w8 64b

Hi guys,

I finished PBv4 but, after program bootloader and connect to USB system not recognize USB device.
I tried get bootloader from SVN compile in MPLABX and C30 and too using XC16.
Compilation OK programming OK ,but same result.

Any hints? thx

Re: BP v4.0c USB no recognize device

Reply #1
Ok guys, problem solved

Help yourself and God will help you :)

Problem was programming speed (I think it's problem of PCB design) because I hasn't similar problem in another construction with same chip.
 
I download PICkit3_GUI_scripting_v03.00beta.zip but when a try to programming bootloader verification was failed.
But in this tool is possible disable fast programming and programming ok wrify ok and PB bootloader cdc connection working.
Firmware update without any problem.

I hope this helps someone with similar problems.

 

Re: BP v4.0c USB no recognize device - signed drivers for w8

Reply #2
At last,

I make test certificate and generate new signed catalog file for mchpcdc.inf
To install:
1. Click Start, click Run, and then in the Run box, type: mmc
2. In Console1 – [Console Root], click File, and then click Add/Remove Snap-in.
3. In Add or Remove Snap-ins, in the Available snap-ins list, select Certificates, and then click Add.
4. In Certificates snap-in, select Computer Account, and then click Next.
5. On the Select Computer dialog box, select Local computer: (the computer this console is running on), and then click Finish.
6. Click OK to close the Add or Remove Snap-ins page.
7. In the unzipped folder, right-click BFXpirate.cer , and then click Copy.
8. Right-click Trusted Root Certification Authorities, and then click Paste.
9. Right-click Trusted Publishers, and then click Paste.
10. In folder right-click mchpcdc.inf, and then click Install.

That's all, have fun.