Skip to main content
Topic: BP v3.6 DOA? (Read 1326 times) previous topic - next topic

BP v3.6 DOA?

Just received a BP v3.6, connected it by USB & nothing - no LEDs, not recognised by the computer. I've tried 2x different computers, 2x different cables & even tried powering it from a USB battery pack. Anything obvious I'm missing, or is this just bad quality control? Really don't want to wait 2 weeks for it to return to Hong Kong & another 2x weeks for a replacement to get delivered :(

Re: BP v3.6 DOA?

Reply #1
Wait, after prodding the components around the USB socket with my finger, it seems to now have sprung into life O_O


Re: BP v3.6 DOA?

Reply #2
if the problem persists, or comes back, just contact Seeed and ask for a replacement. Use this forum page as a reference.. They'll send over another one, without you having to send that one back..

Sorry you had such bad luck at the start of your Bus Pirate experience.
best regards FIlip.

Re: BP v3.6 DOA?

Reply #3
If you have the tools and the guts you can resolder the USB connector and the ft232 chip. Just applying heat to the pins should be enough to reflow the solder and make a solid contact.