Skip to main content
Topic: USB Issues (Read 4672 times) previous topic - next topic

USB Issues

Anyone have trouble with getting this device to be recognized by Windows?  I thought it was supposed to show up as serial device or unknown device or something?  It's not even coming up in device manager as unknown.  Sorry if this is some newb mistake as this is the first time I've used an USB chip.  I thought they needed a different base than 20MHz to divide from?  I'm hoping this isn't related to my other issue where I broke the included crystal and had to go buy another locally.  :(

BTW:  I noticed while looking at the board, that the USB's positive power pin goes nowhere.  I'll see if putting a violet LED+100 Ohm resistor across the USB power pins helps.  Then I'll have to try writing a firmware through a serial adapter that outputs a clock pulse.  (Then I can verify that it is indeed running at the right speed to sync the USB bus)

::EDIT:: Oh heck, it seems that you have to hold the button in to make it work.  I was just experimenting and got to thinking... and had an ahah! moment.  It shows up but gives an error message saying it malfunctioned.  Well this isn't going smoothly.  Back to the drawing board, LOL.

::EDIT::  Got it working - on another port.  Yeah, might be the computer.  Sigh...  OK here's some info that should be in the updater batch files:
"Note:  To make the Flash Destroyer act as a USB device in order to update firmware, you must hold the button down, apply power, THEN hook up the USB cable.  Otherwise, it'll not work."

Re: USB Issues

Reply #1
The fd only enumerates when you put it into bootloader mode by shorting the pcg and pgd pins (as i recall, i did it a while ago now).
Got a question? Please ask in the forum for the fastest answers.

Re: USB Issues

Reply #2
You beat me to it...  But I added some text I think should be in the batch files.  I'll submit a request to commit at the source site.

And 20MHz works because it divides by 5/3.  I have no idea how to implement a 3x frequency multiplier but that seems to be what they used.  Thanks for help even though I eventually solved it myself.  This topic should be helpful though to someone running into USB problems.  I'll leave the blue LED as a consideration for later.  It's not needed to make the device recognized.  Being new to USB means I've got a lot of reading and testing to do before I'm an expert.  It takes patience to learn a whole new electrical standard and set of protocols!  ;)

Possible mod:  Use USB to power it.  Is this safe?  I'd rather use the 9-volt battery clip I soldered directly to the power connector's pins supply 12V to a programmer for example.  However, if I was going to do that, it would be best to just make a new board without all the LEDs and with a daughterboard to connect CPLDs and so on to it.  There are already tons of projects like that 'out there' with ready-made PCB designs.  I was attracted to this project because of the USB access and simple soldering.  What caused me the most trouble was a lack of practice and a soldering iron that refused to stay hot.  Meh, there's something to be said for getting a good soldering iron with thermal feedback.  You sometimes get what you pay for apparently...  Same with using Sn63/Pb37 instead of 60/40 solder.

I'm ordering a low-temp Bismuth alloy bar to make solder with from RotoMetals.  MetalShippers doesn't have it.  I've priced the equivalent premade solder and it's priced by length (one place was $5/foot)/the gram!  Extrusion is needed as well as flux but it should be a good learning experience and I won't be practically burning money.  It's a lot easier to do surface mount with those solders, supposedly.  By the way, since lead is denser, for the same volume of solder, the lead is heavier.  This means in practical terms that a 1 pound roll of lead-free solder is a lot longer than the same weight of lead solder in the same diameter.

::EDIT::  Well I tried but they SVN is being a PITA to even make bug reports on.  I guess I'll have to wait for the author to see this.  Bah, this shouldn't be so hard to report.  It's no wonder there's only 2 whole issues for the SVN repository.  :/

 

Re: USB Issues

Reply #3
Thanks Joe. I added your note to the firmware update batch file and updated SVN.
Got a question? Please ask in the forum for the fastest answers.