Skip to main content
Topic: Board outline not found in .GKO file...but all other fab houses work (Read 235 times) previous topic - next topic

Board outline not found in .GKO file...but all other fab houses work

Hi - I've used DirtyPCBs before, it's one of my favorite fab houses.

But this time I'm getting an error:  "Board outline not found in .GKO file"

I'm using Proteus 8.11. I know how this should be done, it used to work for me.  I draw a 2D graphic box on the MECH1 layer around the design to define the board edge. (I also have some mouse bites and holes on the MECH1 layer).  I then export the Gerbers like this:

Screen-Shot-2021-03-24-at-4-20-04-PM" border="0

Proteus puts out .GBR files, and I rename them to the files DirtyPCB expects.

Here's my Proteus output:
Code: [Select]
TEST3 - CADCAM Top Copper.GBR
TEST3 - CADCAM Bottom Copper.GBR
TEST3 - CADCAM Top Silk Screen.GBR
TEST3 - CADCAM Top Solder Resist.GBR
TEST3 - CADCAM Bottom Solder Resist.GBR
TEST3 - CADCAM Top SMT Paste.GBR
TEST3 - CADCAM Bottom SMT Paste.GBR
TEST3 - CADCAM Mechanical 1.GBR
TEST3 - CADCAM Top Assembly.GBR
TEST3 - CADCAM Drill.DRL
TEST3 - CADCAM Drill.GBR
TEST3 - CADCAM READ-ME.TXT

Here are the files renamed for DirtyPCB (with unneeded or empty files removed):
Code: [Select]
TEST3 - CADCAM Top Copper.gtl
TEST3 - CADCAM Bottom Copper.gbl
TEST3 - CADCAM Top Silk Screen.gto
TEST3 - CADCAM Top Solder Resist.gts
TEST3 - CADCAM Bottom Solder Resist.gbs
TEST3 - CADCAM Mechanical 1.gko
TEST3 - CADCAM Drill.txt

It all worked in the past for me with other boards...but not now with this one. Here's the result:

Screen-Shot-2021-03-24-at-4-11-37-PM" border="0


The board image looks correct, but it has the error message. However, it displays correctly on OSHPARK, JLCPCB, and multiple Gerber viewer apps, all without any errors.

I don't want to place an order with the error message appearing, so I ended up placing the order elsewhere. But can anyone explain why DirtyPCBs gives this error but other fab houses don't? I'd like to stay with DirtyPCBs...

(I can post my Mechanical 1.gko file if someone thinks it would help...)

Thanks...



Re: Board outline not found in .GKO file...but all other fab houses work

Reply #1
Yeah, can you post your gerber files? Also did you verify them with a gerber viewer?

It looks like you panelized this board, maybe that's causing some issues?

Re: Board outline not found in .GKO file...but all other fab houses work

Reply #2
Yeah, can you post your gerber files? Also did you verify them with a gerber viewer?
It looks like you panelized this board, maybe that's causing some issues?

Yes, it's panelized. Yes, it views correctly in online gerber viewers and in ZofzPCB (my preferred PC gerber viewer).

I've already ordered from another house, they accepted it, sent me review images that were correct, have fabbed and shipped the boards.

Two zipped versions of the gerber files are attached. The gerber files are all the same, but the first zip is the direct output from Proteus (which renders correctly online and in ZofzPCB, and which the fab house accepted and fabbed). The second zip is with the filenames modified as per DirtyPCB instructions, and with unneeded or empty files removed.

Note that if you upload the DirtyPCB zip file to OSHPARK, they have no issues with it.

I'd appreciate any help in understanding what the DirtyPCB issue is...thanks.


Re: Board outline not found in .GKO file...but all other fab houses work

Reply #3
I don't know the specifics of DirtyPCB tester.

I see that all files have the board outline but only "Mechanical 1" files have internal slots. Also the board outlines "Mechanical 1" files and other files do not line up exactly.

I tried to line up outlines perfectly and also delete the internal slots. Both cases resulted in the same error message.

Contact us page may help as I don't think Ian is checking out forum messages frequently.

Re: Board outline not found in .GKO file...but all other fab houses work

Reply #4
Thanks, those might be clues for me to pursue. Also I'll reach out directly as you suggest.

Re: Board outline not found in .GKO file...but all other fab houses work

Reply #5
I see that all files have the board outline but only "Mechanical 1" files have internal slots. Also the board outlines "Mechanical 1" files and other files do not line up exactly.

I tried to line up outlines perfectly and also delete the internal slots. Both cases resulted in the same error message.

Yes, Proteus exports the board outline on a Board Outline layer, but most houses don't seem to like that. They suggest drawing the board outline on Mech 1, as well as drawing slots on Mech 1 after laying out the initial panelization. So that's why you saw those characteristics. As to the Mech 1 board outline not lining up with the other layers, I suspect that's because it's drawn later, in the Panelization layout, than the other layers, which are output directly from Proteus.