Skip to main content
Topic: Resurrecting my BB v2.5 (Read 303 times) previous topic - next topic

Resurrecting my BB v2.5


I'd like to resurrect my BB v2.5 but urJtag returns a "TDO seems stuck to 0". I get this error with two different target boards which otherwise seem to work fine when connected to a Segger J-Link.

I'm not sure what I exactly did with my BB before burying it in a box so I followed the instructions at and successfully reprogrammed the buffer with BBv2-JTAGkey-v1.3.svf.

I'm using a hand built urJtag from git and I'm leaving the JP4 open, so powering the buffer with the target 3.3V which I verified arrives to the BB's jtag connector.

How I can move on?


Re: Resurrecting my BB v2.5

Reply #1
I've also run the self-test (from, something seems really wrong here:

Select device:
Device 0 (Serial Number: A
Device 1 (Serial Number: B

SUCCESS (Connected to the FTDI.A)
SUCCESS (reset)
SUCCESS (usb parameters set)
SUCCESS (event chars disabled)
SUCCESS (timeouts set)
SUCCESS (latency set)
SUCCESS (flow control disabled)

        00000001        11111111
        00000010        11111111
        00000100        11111111
        00001000        11111111
        00010000        11111111
        00100000        11111111
        01000000        11111111
        10000000        11111111
        00000000        11111111
        10101010        11111111
        01010101        11111111
        00000000        11111111
        11111111        11111111
Testing complete, errors: 12

At the bottom of the linked page I read "We highly recommend users upgrade to a non-selftest buffer immediately".  Need to understand whether I need to program any special buffer for this test or not.

Re: Resurrecting my BB v2.5

Reply #2
Problem solved. As mentioned in other posts, I should use "cable jtagkey vid=0x0403 pid=0x6010".


Re: Resurrecting my BB v2.5

Reply #3
I'm glad you solved the problem cavokz. Debugging BB issues can be a pain and it usually comes down to 3 things:
* Using "ft2232" instead of "jtagkey" when specifying the adapter. "ft2232" is only used when trying to program the CPLD.
* Not specifying "vid" and "pid" values or using the wrong ones.
* Using wrong "interface"option. Interface 1 is for programming the CPLD and interface 0 (default) is routed to the pins via the CPLD.

You were running the self test without the jumper connections in place I believe, hence the errors. Particularly take a look at JP4. Notmally the CPLD uses the VTG pin to adjust output voltage of the output with the JTAG port but if you put a jumper on JP4, BB will power the circuit wıth 3.3V instead of using it as a voltage reference. Once it passes the self test, you should probably download and install the jtagkey bitstream into the CPLD.