BP V4 not working on MAC

Hacking multi-tool. Get one for $30, including worldwide shipping.

BP V4 not working on MAC

Postby diego » Thu Nov 15, 2012 7:07 am

Hi, i've purchased a BP V4.0
I have a Mac with OSX10.8.2 and I had installed the FTDI driver, but the USB led flash once and then goes off!(the power is on)
in my system profile the ftdi chip is not recognized.

Is possible any issue with ftdi driver that are only for OSX10.7?
diego
Newbie
Newbie
 
Posts: 6
Joined: Thu Nov 15, 2012 6:59 am

Re: BP V4 not working on MAC

Postby tayken » Thu Nov 15, 2012 3:21 pm

Hey diego, welcome to the forum!

BP v4 does not have an FTDI IC, the USB virtual serial port is all done by firmware. So that is normal not to see FTDI. Do you see any other stuff? The USB led just shows USB activity so no worries there. On Linux I was able to talk directly with it without any driver installation, so I'm thinking you have to check out the serial ports carefully.
User avatar
tayken
Developer
Developer
 
Posts: 1381
Joined: Sat Dec 12, 2009 10:58 am
Location: Tokyo, Japan

Re: BP V4 not working on MAC

Postby andersm » Fri Nov 16, 2012 5:08 am

Open a terminal and type "ls /dev/tty.usbmodem*", the Bus Pirate's device should show up once you plug it in. If you have the USB Prober tool installed, look for the communication class device with the vid/pid 0x04D8/0xFB00 (in the current firmware the product string is still "CDC Test").
andersm
Jr. Member
Jr. Member
 
Posts: 60
Joined: Mon Apr 02, 2012 8:13 pm

Re: BP V4 not working on MAC

Postby diego » Sat Nov 17, 2012 9:09 am

finally i've got it (CDC Test appears in system profile)

but i got a problem with the boot loader if i connect the pgd and pgc together, the vreg led switch on!
and on zterm..
HiZ>i
Bus Pirate v4
Firmware v6.0-a3
DEVID:0x1019 REVID:0x0003 (24FJ256GB106 A5)
http://dangerousprototypes.com
HiZ>$
Are you sure? y
BOOTLOADER
### Error: 6 in SerGetBuf

after this i need to close and open again zterm, on the firmware line there is no reference to the bootloader version!
diego
Newbie
Newbie
 
Posts: 6
Joined: Thu Nov 15, 2012 6:59 am

Re: BP V4 not working on MAC

Postby ian » Wed Dec 05, 2012 2:24 am

In v4 you need to tie PGC and PCD together and reset to get to the bootloader. What happens is the bus pirate resets while your terminal is still open, the USB device disappears and the mac freaks out, then it comes back and has an error because you are holding the port open with the terminal.

Soft jump and reset will probably never work in v4, they are left for backwards compatibility with some utilities.
User avatar
ian
Crew
Crew
 
Posts: 10577
Joined: Mon Jul 06, 2009 6:14 am


Return to Bus Pirate Support