Linux and IR Toy problems

USB infrared remote control receiver/transmitter. Get one for $20, including worldwide shipping.

Linux and IR Toy problems

Postby Nigan » Sat May 25, 2019 2:39 pm

Hello everyone,,
I ordered that wonderful USB IR Toy in order to control some of my devices, e. g. a stereo and a LED color stripe with RCs.
I've upgraded the firmware to v22 and use the software from the latest package.
#Edit: The self test works fine! I use Win7 x64 / Linux Mint 15.

Now my IR Toy won't work properly for me. While under windows, I can easily receive / record signals from RCs using RecPlay and WINLIRC. I checked the signals mobdro lucky patcher kodi and the fit the NEC protocol, so they are fine. Sending the recorded signals flashes the IR LED (seen with a cam), but does not influence my stereo nor my LED color stripe at all. Frustrating and I have no idea why.

So I switch to linux, trying to get better results, but did not get any proper result so far.
I tried to connect ttyACM0 using screen and get connected, but the terminal is only black and does not respond anything.
I tried to connect using RecPlay but the programm tells me the firmware number is garbage.
And finally I tried to connect with ckermit, but cannot send or receive at all.

Does anyone have some nice ideas for me, I really have no clue! And I really want to do a light show! ;)
Last edited by Nigan on Tue Jun 04, 2019 9:01 am, edited 1 time in total.
Nigan
Newbie
Newbie
 
Posts: 2
Joined: Mon May 20, 2019 6:09 am

Re: Linux and IR Toy problems

Postby Barf » Sun May 26, 2019 5:52 am

Please forget about ckermit and screen; the protocol is binary.

I do not know what is going on (the complaint about garbage firmware version may indicate a real problem). I suggest that you try with IrScrutinizer, it may not be the productive solution you are looking for, but if it works, we can go from there.
Barf
Jr. Member
Jr. Member
 
Posts: 73
Joined: Mon Jul 07, 2014 3:12 pm


Return to USB Infrared Toy