LcdProc

USB and serial backpack PIC_LCD_backpack for HD44780 character LCD screens.

Re: LcdProc

Postby ian » Tue May 01, 2012 2:36 am

I bookmarked this and will release a new firmware that gives dumb replies to the new commands this week. Any help testing would be really great.
User avatar
ian
Crew
Crew
 
Posts: 10803
Joined: Mon Jul 06, 2009 6:14 am

Re: LcdProc

Postby thatguy666 » Wed May 02, 2012 1:59 am

Hello,
I finally found some time to look at this tonight. I have lcdproc-0.5.4 compiled but, it gives me the following error when i try to run the server LCDd;

Could not open driver module server/drivers/MtxOrb.so: server/drivers/MtxOrb.so: cannot open shared object file: No such file or directory
Driver [MtxOrb] binding failed
Could not load driver MtxOrb
There is no output driver
Critical error while initializing, abort.

Still looking into this
thatguy666
Newbie
Newbie
 
Posts: 16
Joined: Wed Feb 22, 2012 12:08 am

Re: LcdProc

Postby ian » Wed May 02, 2012 4:32 am

Would anyone still subscribed please test out the v1.1beta1 firmware with LCDproc:

viewtopic.php?f=60&t=3992&p=39940#p39940

It now replies with the correct number of bytes when the 5,6, and 7 commands are sent. The reply is always 0x00, so we may need to do some research into the correct values if that causes issues.
User avatar
ian
Crew
Crew
 
Posts: 10803
Joined: Mon Jul 06, 2009 6:14 am

Re: LcdProc

Postby thatguy666 » Thu May 03, 2012 1:03 am

Hello,

The firmware updated correctly and without any issue.
The device is loaded as ttyAMC0.
I ran it with the lcdproc version in the ubuntu repo.

The following error message occurs when trying to run LCDd

sudo LCDd
MtxOrb: open(/dev/ttyAMC0) failed (No such file or directory)
Driver [MtxOrb] init failed, return code -1
Could not load driver MtxOrb
There is no output driver
Critical error while initializing, abort.

I can do a comparison with an eariler version of the firmware if you need.
thatguy666
Newbie
Newbie
 
Posts: 16
Joined: Wed Feb 22, 2012 12:08 am

Re: LcdProc

Postby 240glt » Mon Mar 03, 2014 3:40 pm

Hi,

I just finished soldering a 20x4 LCD display to the LCD backpack. I connected it with USB to my Linux mint PC. I installed the LCDProc with apt-get.
I have set it up to use the MtxOrb driver, with the following settings:

Device=/dev/ttyACM0
Size=20x4
Type=lcd
Contrast=480
hasAdjustableBacklight=yes
Brightness=1000
OffBrightness=0
Speed=19200

That works, but the LCD shows some random block characters at some places. If I change the hasAdjustableBacklight to "no", then the displayed characters are correct. But then the backlight flickers with high speed.

Has anyone else experienced this? Any good ideas? :)
240glt
Newbie
Newbie
 
Posts: 2
Joined: Mon Mar 03, 2014 3:33 pm

Re: LcdProc

Postby assassins » Thu Sep 04, 2014 4:17 pm

Hi,

have exactly same problems you described. I will just compile newest lcdproc, Maybe it helps. Or maybe firmware update for the usb backpack.

greets
assassins
Newbie
Newbie
 
Posts: 3
Joined: Thu Sep 04, 2014 4:13 pm

Re: LcdProc

Postby assassins » Thu Sep 04, 2014 4:23 pm

i will also try to connect via UART to my Raspberry instead of USB
assassins
Newbie
Newbie
 
Posts: 3
Joined: Thu Sep 04, 2014 4:13 pm

Previous

Return to USB serial LCD backpack