No response after fw upgrade

Hacking multi-tool. Get one for $30, including worldwide shipping.

No response after fw upgrade

Postby Knirps » Tue Mar 06, 2018 3:21 am

Hello,

I tried to update my Bus Pirate V3a to the version 7 community firmware but accidentally i selected the wrong file at the first time (V4 firmware). It was no problem to flash the correct V3 firmware directly afterwards but now i did not get any response from the device via serial consol.

It is no problem to enter the bootloader again by shorting PGC&PGD and uploading a new FW. I also tried to go back to V5.10 Version of the firmware as it was before but it ends with the same behaviour.

HiZ>i
Bus Pirate v3a
Firmware v5.10 (r559) Bootloader v4.4
DEVID:0x0447 REVID:0x3046 (24FJ64GA002 B8)
http://dangerousprototypes.com

Do anybody now how to proceed to unbrick the device or it is gone forever ?

best regards,
Knirps
Knirps
Newbie
Newbie
 
Posts: 2
Joined: Tue Mar 06, 2018 3:15 am

Re: No response after fw upgrade

Postby USBEprom » Tue Mar 06, 2018 1:53 pm

Hi Knirps.
What do you mean exactly?
If your Bus Pirate v3a with firmware 5.10 respond while issuing command "i" and it also can enter the bootloader mode allowing to load firmware, it seems to me that it works just fine as it is expected.
Can you please explain exactly what is wrong, where, when and while doing what?
Thanks.

Be seeing you.

U.Sb
USBEprom
Full Member
Full Member
 
Posts: 158
Joined: Wed Mar 14, 2012 4:09 pm

Re: No response after fw upgrade

Postby Knirps » Wed Mar 07, 2018 2:30 am

Hi USBEprom,

sorry for the confusing. The "i" Info was extracted before the fw update happen just to show which HW rev and bootloader version was used. After the "incident" the BP do not response to any serial command.

After the wrong FW update i get the device into the bootloader mode via shorting PGC&PGD and according to the "pirate-loader" output it is no problem to flash any firmware. But after an reset of the device it do not response to any serial input.

cheers,
Knirps
Knirps
Newbie
Newbie
 
Posts: 2
Joined: Tue Mar 06, 2018 3:15 am

Re: No response after fw upgrade

Postby USBEprom » Wed Mar 07, 2018 3:51 pm

Hi Knirps.
Ok, thank you for your explanation.
I believe the problem you are facing is due this:

viewtopic.php?f=4&t=435&hilit=rescue#p3743

Possible solutions require the use of PICkit2 or ICD2 type programmers, please take a look at these:

viewtopic.php?f=4&t=435&hilit=rescue

viewtopic.php?f=4&t=6029&p=55578&hilit=rescue#p55578

Since what I have read I do not think you can fix the matter in other way, sorry.

Be seeing you.

U.Sb
USBEprom
Full Member
Full Member
 
Posts: 158
Joined: Wed Mar 14, 2012 4:09 pm

Re: No response after fw upgrade

Postby tayken » Thu Mar 08, 2018 8:56 am

Seems like the fuses are done for. But on the other hand fuses being correct should mean that some values are intact as the bootloader and the firmware share the same fuse values which set the crystal frequency and other stuff.

But the easiest way would be is to reprogram the PIC from scratch. You can use a PIC programmer as USBEprom suggested or if you have another Bus Pirate, it can be used to program the PIC on a Bus Pirate v3a as well. http://dangerousprototypes.com/docs/Pir ... Programmer
User avatar
tayken
Developer
Developer
 
Posts: 1520
Joined: Sat Dec 12, 2009 10:58 am
Location: Tokyo, Japan


Return to Bus Pirate Support