Panasonic Remote not being interpreted.

USB infrared remote control receiver/transmitter. Get one for $20, including worldwide shipping.

Panasonic Remote not being interpreted.

Postby mythman » Wed Apr 27, 2016 4:18 am

Hey all,

I have a Panasonic TV I am controlling with one of those Universal remotes. When I point it at the IRtoy in irman it flashes when I press a button but I cannot for the life of me get lircd to work with it.

irrecord says irrecord: gap not found, can't continue even though the LED flashes.

Is this some exotic remote protocol? How can I debug what the issue is?

Thanks.
mythman
Newbie
Newbie
 
Posts: 4
Joined: Wed Apr 27, 2016 3:41 am

Re: Panasonic Remote not being interpreted.

Postby Barf » Fri Apr 29, 2016 2:56 am

irrecord is not exactly a modern way of capturing IR... Let me suggest that you try IrScrutinizer instead. If Lirc is the ultimate goal, it can generate Lirc files for you.

You need to update the FW on the IrToy to 2.2 for use with IrScrutinizer, but that is a good idea anyhow.

The Panasonic protocol is well known. The codes for Panasonic TVs can be found on the Internet.

Under all circumstances, forget the irman mode!.
Barf
Jr. Member
Jr. Member
 
Posts: 64
Joined: Mon Jul 07, 2014 3:12 pm

Re: Panasonic Remote not being interpreted.

Postby mythman » Fri Apr 29, 2016 2:37 pm

Hmm never heard of IrScrutinizer before. Might also be useful trying to debug why my Revo RL80 U22 CIR appears to do nothing as well.

As is though upgrading to lirc-0.9.3+ and using it in the irtoy mode things settled down. At least on my laptop they did. On the Raspberry Pi all went very weird even using the same source so dunno what went on there.

For the record the firmware on the IRtoy is 2.2.

Thanks
mythman
Newbie
Newbie
 
Posts: 4
Joined: Wed Apr 27, 2016 3:41 am

Re: Panasonic Remote not being interpreted.

Postby Forage » Tue May 10, 2016 2:11 am

mythman wrote:irrecord says irrecord: gap not found, can't continue even though the LED flashes.


I ran into the same issue. With irrecord I had to use --force and after that run irrecord again with --analyse to clean up the new config file.

Let me know if this helps.
Forage
Newbie
Newbie
 
Posts: 31
Joined: Sat Jul 12, 2014 7:01 am


Return to USB Infrared Toy