IRToy stops working after pc resumes from standby

USB infrared remote control receiver/transmitter. Get one for $20, including worldwide shipping.

Re: IRToy stops working after pc resumes from standby

Postby Doug » Sun Mar 04, 2012 10:59 am

Well, the trial didn't go so well. I experienced the same issues as you, mba.

Doug
Doug
Newbie
Newbie
 
Posts: 23
Joined: Wed Apr 27, 2011 12:27 am

Re: IRToy stops working after pc resumes from standby

Postby odem » Fri Apr 13, 2012 10:41 am

Hi,

i also have the same problem that the IRToy stops working after pc resumes from standby.
I would like to know if there is any solution now.
btw i'm using windows 7.

odem
odem
Newbie
Newbie
 
Posts: 1
Joined: Fri Apr 13, 2012 10:36 am

Re: IRToy stops working after pc resumes from standby

Postby ian » Tue Apr 17, 2012 10:09 am

@ian: the microchip usb stack was replaced for a reason? Maybe either JTR or Honken could comment on whether the stack is robust against host going into standby? And maybe they had an idea of how to solve this issue?


The old stack was not redistributable, so we moved to a truly open source one. I can release a limited firmware based on the old stack, but it will not be supported by WinLirc, etc as a native USB IR Toy, only as a IR Man.

I assume they may have an idea, but we depend on volunteers so if it is not something they want or need it may never get done. This issues is a high priority for me, but there's not really any way for me to hack us out of it. It will definitely take some external support.

@Pablik - it sounds like you may be having a problem related to the IR Toy drawing too much power, or bad IR Toy hardware. Any info on the specs on this system (mother board, etc)? I have never heard of a similar issue. I am going to split this to a new thread because it sounds like a separate issue.
User avatar
ian
Crew
Crew
 
Posts: 10803
Joined: Mon Jul 06, 2009 6:14 am

Re: IRToy stops working after pc resumes from standby

Postby fwb » Mon Jan 14, 2013 11:48 pm

I am having a similar problem, except with restarts. When the computer restarts (which I can't avoid forever because of updates), IRToy will stop working ("WinLRC failed to initialize") and show an orange LED until I unplug it and plug it back in. Does the new beta firmware 23 fix it? I'm at a loss, this is a huge hindrance to functionality since it's integral to my automation system which is supposed to be hands-off.
fwb
Newbie
Newbie
 
Posts: 5
Joined: Wed Jun 27, 2012 10:44 pm

Re: IRToy stops working after pc resumes from standby

Postby nanu » Fri Jan 25, 2013 4:29 pm

fwb wrote:I am having a similar problem, except with restarts. When the computer restarts (which I can't avoid forever because of updates), IRToy will stop working ("WinLRC failed to initialize") and show an orange LED until I unplug it and plug it back in. Does the new beta firmware 23 fix it? I'm at a loss, this is a huge hindrance to functionality since it's integral to my automation system which is supposed to be hands-off.


Perhaps check your BIOS settings for a means to disable USB power if not needed... I posted the same problem a while back. Here, I have since dealt with it, meaning, I use a USB extension cord to unplug and replug the cable leading to the IRT. I got some USB mini jacks and plugs, in order to construct an intermediate power switch, instead of hacking a USB cable, but...procrastination.
nanu
Newbie
Newbie
 
Posts: 3
Joined: Mon Dec 10, 2012 3:38 pm

Re: IRToy stops working after pc resumes from standby

Postby p1ngb4ck » Fri Feb 22, 2013 5:34 am

Just my 5 cents :
Since I dont use Windows but Gentoo Linux, this may or may not apply to your problem, but in my case, I simply put the IR-Toy to bootloader mode automatically when going into standby (dunno whether this can be automated in windows too) and reset the device on resume. Works just fine as far as I can tell now.
p1ngb4ck
Newbie
Newbie
 
Posts: 4
Joined: Fri Feb 01, 2013 7:25 am

Re: IRToy stops working after pc resumes from standby

Postby Jani- » Wed Mar 13, 2013 10:42 am

fwb wrote:I am having a similar problem, except with restarts. When the computer restarts (which I can't avoid forever because of updates), IRToy will stop working ("WinLRC failed to initialize") and show an orange LED until I unplug it and plug it back in. Does the new beta firmware 23 fix it? I'm at a loss, this is a huge hindrance to functionality since it's integral to my automation system which is supposed to be hands-off.
I just switched to IRToy v1 and I'm having the same problem. I noticed the device manager says there's an unknown device and if I see the events of the device, there's this:
Code: Select all
Device USB\VID_0000&PID_0002\5&385a3465&0&2 had a problem starting.

Driver Name: null
Class GUID: {00000000-0000-0000-0000-000000000000}
Service:
Lower Filters:
Upper Filters:
Problem: 0x2B
Status: 0x0


EDIT: sometimes there's the LED and sometimes not.. So, a race condition?
EDIT2: I mean to say this happens for me even if I just shutdown my computer and start it the next day. Not always, but some times.
Jani-
Newbie
Newbie
 
Posts: 8
Joined: Wed Dec 08, 2010 12:04 pm

Re: IRToy stops working after pc resumes from standby

Postby Owel » Wed May 29, 2013 7:41 am

Hi,
I'm using the Toy with windows 7 64bit and WinLirc.
everytime I start the PC the Toy is not working and WinLirc complains.
I simply remove the Toy from the pc an reatach it. Now WinLirc is working and also the Toy.
After a Reboot the Toy works smoothly, but when the PC is off for a longer time, the Problem comes up..

Any suggestions?
Owel
Newbie
Newbie
 
Posts: 9
Joined: Wed Mar 07, 2012 2:00 am

Re: IRToy stops working after pc resumes from standby

Postby dukey » Wed May 29, 2013 8:01 am

are u suspending the pc ?
dukey
Full Member
Full Member
 
Posts: 219
Joined: Thu Jul 08, 2010 2:18 pm

Re: IRToy stops working after pc resumes from standby

Postby Jani- » Sat Jun 01, 2013 12:59 am

I'm on Windows 8 x64 and I'm using the hybrid boot feature, so I'm kinda suspending the PC.
Jani-
Newbie
Newbie
 
Posts: 8
Joined: Wed Dec 08, 2010 12:04 pm

Re: IRToy stops working after pc resumes from standby

Postby dukey » Sat Jun 01, 2013 3:45 am

I don't use win8, but from what I recall it doesn't really shut down, it sort of suspends, hence the fast boot times. I think restart does a proper reboot.
dukey
Full Member
Full Member
 
Posts: 219
Joined: Thu Jul 08, 2010 2:18 pm

Re: IRToy stops working after pc resumes from standby

Postby yiank » Sun Jun 02, 2013 3:25 pm

I have the same problem with Windows 7 32bit.

I think p1ngb4ck suggestion (to put the IR-Toy to bootloader mode automatically when going into standby) would be a solution but I can't really get the ir toy out of the bootloader mode. The led stays on and it is not responding to the "fw_update -reset -vid 0x04D8 -pid 0xFD0B" command. Any ides how to exit the bootloader in windows7 (or any other solution to the standby problem)?
yiank
Newbie
Newbie
 
Posts: 1
Joined: Sun Jun 02, 2013 3:17 pm

Re: IRToy stops working after pc resumes from standby

Postby Jani- » Sat Jun 22, 2013 12:48 pm

I think I found a workaround. I ditched WinLIRC and its IRToy plugin and now I'm using EventGhost with its IRMan driver and I haven't faced this issue. One can hope this solves the problem :)

If anyone wants to narrow down the problem, there are a few things that could be tried:
  • Delay WinLIRC initialization
  • IRMan driver with WinLIRC
  • Debug the initialization phase

EDIT: a month later, the toy is perfect with IRMan, I've had zero problems since.
Jani-
Newbie
Newbie
 
Posts: 8
Joined: Wed Dec 08, 2010 12:04 pm

Re: IRToy stops working after pc resumes from standby

Postby Jani- » Thu Aug 22, 2013 5:51 am

Double-posting to cause activity and possible notifies.

Without fully understanding the problem, this sounds a bit like the case: https://plus.google.com/116960357493251 ... Zpndv4BCCD. I wonder how Windows behaves with this..

Using IRMan with IRToy is still working without any problems at all, so I wonder who is the guilty one! :p
Jani-
Newbie
Newbie
 
Posts: 8
Joined: Wed Dec 08, 2010 12:04 pm

Re: IRToy stops working after pc resumes from standby

Postby enghooda » Fri May 22, 2015 6:36 am

Hello,
Just received my IRToyv2 Last Monday , Updated it to last firmware V22, and I got what I expected form it , nice Job ;)

I notice that it does not respond after a while , but unplugging it then plugging it back always worked.

but when I used it on a remote PC to control a Home Appliance , It worked for a while then gone unresponsive .

and I had to figure a solution that works remotely ...

Tried all suggested solutions devcon , restart , disable then enable (Unknown device) , ...

Nothing could Power cycle it remotely .

Thought of trying IRMan driver but could not find a download source for it.
Link here is broken : "my spamy link" intolect(dot)com(backslash)irmandetail(dot)htm

Any tips would help , Thank You :)
enghooda
Newbie
Newbie
 
Posts: 1
Joined: Fri May 22, 2015 6:17 am

PreviousNext

Return to USB Infrared Toy