Skip to main content
Topic: No EEPROM/flash device found. (Read 3191 times) previous topic - next topic

No EEPROM/flash device found.

Hey everyone, im very new to hardware hacking and just got a bus pirate. Been getting this error, I tried a few different things.

First of all the flash im looking at is an MD25Q128, tried to link datasheet but got flagged, for spam, its on google first link.

I set it up to connect with SPI, the datasheet and flashrom wiki give the same pinouts

Putty baud rate is 115200

The setup:
Soic 8 clip wired up to the bus pirate.

To test if I could get a connection I turned my device on, got feedback saying bus pirate couldnt keep up.

Im trying to google my way through this but am a little stuck, id appreciate any help anyone can offer. If you need any more information from me, please let me know.


Re: No EEPROM/flash device found.

Reply #1
Hi TotallyNotCarson.
I know nothing, however it is possible FLASHROM can not handle that kind of SPI chip.
Indeed some of the 25Q128 shown on are reported as "?", you have to verify it by yourself.
Even if FLASHROM does not support the chip, maybe alone the Bus Pirate can still manage it.
Please take a look and read carefully these:


Manage the pin7 (HOLD#/ - RESET#) is quite tricky, you have to read the content of the STATUS REGISTER as bit 9 (QE = S9).
In order to retrieve the value of QE you need to read it from the STATUS REGISTER 2 by using command 35h sending it as:

[0x35 r]

Would you please describe how exactly you are connecting the whole chip?

Be seeing you.