Skip to main content
Topic: [SOLVED] How to access bootloader on firmare v6.2 (Read 803 times) previous topic - next topic

[SOLVED] How to access bootloader on firmare v6.2

I have a BusPirate 3.5 (SparkFun version) and I wanted to see if I could update it to the v7.0 firmware and the v4.5 bootloader. 
It's currently running the v6.2 beta firmware because I was using to flash the BIOS in my ThinkPad T60 and that firmware sped up the SPI access.

Code: [Select]
HiZ>i
Bus Pirate v3.5
Firmware v6.2-beta1 r1981  Bootloader v4.4
DEVID:0x0447 REVID:0x3046 (24FJ64GA002 B8)
http://dangerousprototypes.com

Now, I wanted to update this to Bootloader v4.5 and possibly Firmware v7.0, but I ran into a problem.  When I try to enter the bootloader, using the `$` command in the console, nothing happens.  This was discussed here: https://github.com/BusPirate/Bus_Pirate/issues/38

It turns out that is a bug in the V6.2 firmware.  So, is there any way to "fix" my BusPirate, so I can access the Bootloader and upgrade it to v4.5?

EDIT: I'm a moron.  Using a jumper between PGC/PDG allowed me to do what I wanted...