Skip to main content
Topic: OLS is a nightmare. Help me make mine work. (Read 1567 times) previous topic - next topic

OLS is a nightmare. Help me make mine work.

I have a 20Mhz OLS that never really worked well. Sadly, I'm stuck away from an oscilloscope for a while and really need a logic analyzer immediately, so I'm forced try to use it.
Unfortunately, I can't seem to get anything to work, despite spending two entire days on it.

I'm able to burn new firmware onto the device using a pickit3, but unfortunately it seems like the newest built version of the code for a 20mhz crystal doesn't play nicely with ols-fwloader. Most of the hex files available don't work at all. (I'm assuming they're for 16Mhz crystals.)

I eventually found the source code for the pic firmware (finding it was an adventure because everything related to the project is so incredibly disorganized), but there is no mplab project file, and I'm having trouble trying to figure out how to get the microchip USB library to work with the OLS source.

So, I'm appealing to you (Ian) to provide a current hex file for the hardware I bought from you (in pre-order, I might add, along with bus pirates and other crap you guys designed), which never worked properly, and has been a nightmare trying to even figure out how to update. I now remember why I gave up years ago and just threw it in a box.

I hope you are ashamed of your work on the OLS project, because you certainly should be.
Sending this directly to your Contact page and as a post in the forum.

Re: OLS is a nightmare. Help me make mine work.

Reply #1
Wow, that is a bit harsh. As the name suggests, these are prototypes, you cannot expect them to work like a Tektronix one.

But I feel your pain. OLS is a particularly painful project as it was a collaboration between two companies and the documentation is split between them. Add changing links at the Gadget Factory site and it becomes a total mess.

The crystal is 20 MHz, even documented at the hardware documentation.

I got the latest firmware and bitstream from the download page and never had a problem since that day.

Re: OLS is a nightmare. Help me make mine work.

Reply #2
The ols-0308 updater is a complete fail on linux. I gave up even figuring out why it wasn't working.
It gives me different errors now compared to before I built ols-fwloader myself:

Code: [Select]
Logic Sniffer ROM loader v0.3 (November 9, 2010)
Unknown parameter 'line'
Logic Sniffer ROM loader v0.3 (November 9, 2010)
Unknown parameter 'line'
Press any key to continue...
Code: [Select]
ols-fw-update: error while loading shared libraries: cannot open shared object file: No such file or directory
Press any key to continue...

Wasn't getting that error before. You can see how useful it is, though.

I managed to get the ols-fwloader code to compile and run from the git repository, but it can't talk to the device because I can't put the device into BOOT mode while it's enumerated.
This is because I apparently had the original pic firmware on it, which wasn't capable of updating without manually flashing the code onto the device.
So I tried to use my buspirate for that. But the picprog software for doing that is distributed in a random forum post as a zipfile with a hex image and an .exe file.... no source code, so no hope of compiling that on linux. I suppose the source code is probably out there somewhere, but if it's like any of the rest of this stuff, it takes 10 hours googling and trudging through forum posts to find it.

Since that was a fail, I figured I'd try my luck with a pickit. Luckily I'm in Taiwan right now, so I just hopped over the electronics market and picked one up. After installing mplab it was a piece of cake to burn images. But most of the pic images in the OLS_Upgrader folder don't work.

old-versions/OLSv1-firmware-v06-20MHz.hex  allows the device to enumerate.
OLSv1.04-firmware-v2.3.hex  seems to let me enter BOOT mode, but the device doesn't enumerate, so that's no help.
The other images I tried all were failures.

You commented that:
The crystal is 20 MHz, even documented at the hardware documentation.

And that's all well and good, except that on some of the devices it is 16 Mhz (I forget where the forum post was that mentioned that), and in, which I found who knows where, things are even commented out so that it compiles for 16Mhz:

Code: [Select]
    //#ifdef XTAL_20MHZ
    //#pragma config PLLDIV = 5          //Divide by 5 (20 MHz oscillator input)
    #pragma config PLLDIV = 4          //Divide by 4 (16 MHz oscillator input)

I don't expect open hardware to work as well as a Tek or Keysight or even Saleae analyzer.

I just expect that "open hardware" --- which I paid for --- should have reasonably organized documentation, and that the source code should all be available without searching through dozens of forum threads. There's no reason that information couldn't all have been put in one place. It's just sheer laziness.


Re: OLS is a nightmare. Help me make mine work.

Reply #3
Hi enigma32.
Honestly I know little about OBLS, but looking in the forum and on the internet I found the tools and explanations for updating it with Windows, Linux and Apple.
That's right, it was released with a 20MHz XTAL (OLS v1.01) and 16MHz XTAL (OLS v1.04): ... d_partlist


Here are some threads in the forum where are listed multi platform tools for the upgrading of the OLS:
viewtopic.php?f=23&t=1780 (OLS files and utilities - Windows, Linux, Mac)

index.php?topic=552.msg4909#msg4909 (Firmware Update using Linux)

viewtopic.php?f=23&t=1915 (PIC firmware v3.0 for Demon core v3)

viewtopic.php?f=23&t=675 (Logic Sniffer downloads, help, FAQ)

viewtopic.php?f=23&t=1654 (Brand new OLS (boot)loader tool - Windows and Linux) (working under Linux, Apple and Windows)

In my opinion best options are pump-loader and ols-fwloader, both are multiplatforms for Linux, Apple and Windows.
pump-loader is contained in the ols-0308OLS_Upgraderwinbin path inside the ols-0308 package that can be downloaded from here:

ols-fwloader is here: ... r.Download

Maybe something can be of help.

Be seeing you.