Skip to main content
Topic: Bus Pirate PIC programmer v0.1 (continued)... (Read 32785 times) previous topic - next topic

Re: Re: Bus Pirate PIC programmer v0.1 (continued)...

Reply #15
Hi, sorry you are having problems! I have to lean towards user error, since it was reading before in the other post it is not likely a dead/fried PIC. Maybe check with a multi meter for shorts to ground on the programming pins (PGC/PGD), if nothing else this gives an excuse to reconnect the wires which might of just had bad connections between the two.  Short of a loose connection my best guess would be inadequate power being supplied to the target, in which case it's just not powering up, that should be evident if you monitor the voltage on targes VCC line.

Re: Re: Bus Pirate PIC programmer v0.1 (continued)...

Reply #16
has v4 already been updated  to support pic protocols ?

Re: Bus Pirate PIC programmer v0.1 (continued)...

Reply #17
I've just finished building my BP3, and am trying to program the bootloader with my BP4 using:

Code: [Select]
picprog -p buspirate -u COM3 -s 115200 -c 24FJ64GA002 -t HEX -w BPv3-Bootloader-v4.4.hex -E -V


COM3 is my BP4. -c is my target mcu.

But i keep receiving this:

Code: [Select]
Found '24FJ64GA002' in programming database :) index = 2
Checking for 24FJ64GA002 attached to programmer...

Wrong device: 0X4704 (ID: 0X4704 REV: 0)

I've not found any shorts and both of the programming pins are not shorted to ground. Any help would be greatly appreciated!

EDIT: have made a new thread viewtopic.php?f=4&t=8059