Skip to main content
Topic: FT2232H and XC9572XL (Read 3090 times) previous topic - next topic

FT2232H and XC9572XL

Newbie at JTAG, CPLD dev, etc.  The plan is to use a FT2232H breakout board and a XC9572XL CPLD development board.  Both are needed for developing a project I have in mind, but would also like to use the FT2232H board to program the XC9572XL via JTAG. Can this be done directly, i.e. no extra hardware buffering needed between the two? If anyone has done it already, I'd like to hear from you.

Re: FT2232H and XC9572XL

Reply #1
urJTAG has a FT2232H board selection. I would try that one.

Re: FT2232H and XC9572XL

Reply #2
Have at last acquired the hardware and hooked it all up. Also downloaded and built the latest version of UrJTAG.
The jtag 'cable' command gives output:
Code: [Select]
Connected to libftd2xx driver.
But the 'detect' command gives:
Code: [Select]
warning: TDO seems to be stuck at 1
Scoping it shows the JTAG lines changing state; 5MHz pulses on TCK. TMS is low all the time during the 'detect'; TDI is low most of the time.

There is a note at http://dangerousprototypes.com/docs/CPL ... _SVF_files [ dated April 2014 ]
Quote
urJTAG does not seem to work with the XC9572XL CPLD.
We expect a fix eventually.
Anyone actually got this to work with the XC9572XL yet?

I'm guessing that the problem is in UrJTAG.
Has anyone got the FT2232H board to work with the XC9572XL using any other software (Linux for preference)?

Re: FT2232H and XC9572XL

Reply #3
Which cable command are you using? Don't use jtagkey, use ft2232.

Re: FT2232H and XC9572XL

Reply #4
Yes, I was using 'cable ft2232'.

Also tried with OpenOCD, and similar results:
Code: [Select]
Error: JTAG scan chain interrogation failed: all ones
Beginning to wonder if my target device might be broken ... although it works in the sense that it arrived with a built-in demo config that flashes the on-board LEDs, and that still works, but of course that doesn't preclude the JTAG part being dead.  But I expect it's more likely a set-up error on my part!  :)

Re: FT2232H and XC9572XL

Reply #5
Do you include vid and pid during cable ft2232 command? Also check which interface you are using. Those were my mistakes when I was dealing with mine.

Re: FT2232H and XC9572XL [SOLVED]

Reply #6
No vid and pid, unspecified interface so assume 0. However, can see signals at device on scope, so I knew it was the right one.

Decided to scope it more thoroughly to check all signals had correct timing - and found one with decidedly odd voltage levels.  Rechecked header, one pin (despite all passing continuity checks) was showing high resistance.  Grrr!  Never trust crimp connections!  A dab of solder and now all works just fine.  UrJTAG and OpenOCD both happy with it.

Thanks for taking an interest.  Hope this post may help anyone else who may be using unsoldered header lead pins!