Skip to main content
Topic: Faulty binding posts on ATX v1.2 (Read 4020 times) previous topic - next topic

Faulty binding posts on ATX v1.2

The last batch of ATX Breakout Boards (v1.2) we received from Seeed Studio (Dec '14) had faulty binding post caps. Most of the binding post caps in this batch have a moulded plastic female thread about halfway up instead of the metal threaded insert that used to be standard. This makes it impossible to engage the threads if you have more than one terminal ring on the post.

Does anyone know where I might obtain some of the original binding posts & caps?

Re: Faulty binding posts on ATX v1.2

Reply #1
Could you provide some pictures?

Re: Faulty binding posts on ATX v1.2

Reply #2
A photo of the binding post caps is attached.
The one on the right, with the metal thread insert, is the original style.
The one on the left is what came with the last half-dozen boards we received. These have a plastic female thread that starts about halfway up the bore.
I am looking for a source of the original (metal lined) type to replace the faulty plastic ones.

Re: Faulty binding posts on ATX v1.2

Reply #3
My first hit on ebay: http://www.ebay.com/itm/VS2-5-pair-Ampl ... 3a9ae496a0

 I ordered some some time ago (can't remember whether it is from this seller or not) I'm not too fond of the quality and suggest to get better ones from mouser of digikey. cheapest one I found quickly: http://nl.mouser.com/ProductDetail/Delt ... VPtWOXMigd

Re: Faulty binding posts on ATX v1.2

Reply #4
Yeah, I've tried a few of those sources but they appear to be the same all-plastic (bad) ones that come with the new ATX v1.2 boards.
As a workaround for now, I'm splicing three or four wires into one terminal ring, but this is not ideal. I'd much prefer the original metal-threaded binding posts.

Re: Faulty binding posts on ATX v1.2

Reply #5
http://www.ebay.com/itm/320757330068

seem to be the better posts with brass inserts.