Skip to main content
Topic: Problem when installing on Rasbian - missing liblirc.so.0 (Read 4604 times) previous topic - next topic

Problem when installing on Rasbian - missing liblirc.so.0

I got a problem when installing IRToy on Rasbian.
I got a fallowing error:
irrecord: error while loading shared libraries: liblirc.so.0: cannot open shared object file: No such file or directory

when trying this command:
irrecord -n -H irman -d /dev/ttyACM0 RemoteXXX.conf

Do you have any solutions?

Is there any in depth tutorial for installation on Rasbian with every step? Maybe I am missing something?

Re: Problem when installing on Rasbian - missing liblirc.so.

Reply #1
Since, as far as I am aware, there was no liblirc.so in Lirc 0.9.1 and earlier, I conclude that you have been downloading the current sources from  GIT and compiled it yourself.

The error message means that the executable cannot find a shared library that it needs. Either the latter was not installed in the proper place, or the executable cannot find it. You did "make install", not just mv-ing stuff around, did you? You may point LD_LIBRARY_PATH to the actual location of the shared library to run the contained programs, but that is not a permanent solution.

Assuming that you did follow the instructions, please report the problem, giving all relevant data, to the Lirc mailing list, see  https://lists.sourceforge.net/lists/listinfo/lirc-list . You will have to subscribe before you can post.

Re: Problem when installing on Rasbian - missing liblirc.so.

Reply #2
Hello,

any news on this topic. I had run into the same error.

thanks

jan

Re: Problem when installing on Rasbian - missing liblirc.so.

Reply #3
[quote author="jantum"]Hello,
any news on this topic.
jan[/quote]

The news is that the current version is 0.9.2a,

Apart from that, the original problem is of the category "Linux beginner problems". I gave constructive suggestions for solving it, Did you (or  the OP) even try them?

Re: Problem when installing on Rasbian - missing liblirc.so.

Reply #4
Nvm. I fixed the issue...

Re: Problem when installing on Rasbian - missing liblirc.so.

Reply #5
Can you share how you fixed the issue?  I'm running into this same error compiling/installing the latest LIRC from src, which is like 0.9.3 at the moment.  I'm seeing this issue on both the Raspberry Pi (Raspbian) as well as doing the same thing on Xubuntu.

Re: Problem when installing on Rasbian - missing liblirc.so.

Reply #6
I ran:

Code: [Select]
sudo ldconfig

after installing lircd and it helped to remove the error liblirc.so.0: cannot open shared object file