Skip to main content
Topic: Buspirate 4 Faulty? (Read 3262 times) previous topic - next topic

Buspirate 4 Faulty?

To Whom It May Concern:

I recently ordered the Buspirate4, After numerous attempts to get it working in different operating systems : Linux/Windows/Mac os x, I have come to the conclusion that it is defective/faulty.

I am unable to upgrade the firmware as well.
unable to do so, it complains about connecting to the "Bootloader" and i have put the device in to boot loader mode successfully.? please advise me anything I could do?


Thank you

Re: Buspirate 4 Faulty?

Reply #1
Are you still having the same problem?

Re: Buspirate 4 Faulty?

Reply #2
Same here, it's a shame, BPv3 was so good, but quality control here seems to have gone out the window.

Re: Buspirate 4 Faulty?

Reply #3
From the Product Page at Seeedstudio:

Quote
Each Bus Pirate v4 is tested before it leaves the factory, but please keep in mind that v4 is still experimental, unproven hardware. If in doubt please buy the cheaper Bus Pirate v3

I think it is somewhat disengenuous to complain in the circumstances.

Re: Buspirate 4 Faulty?

Reply #4
[quote author="Jascol"]To Whom It May Concern:

I recently ordered the Buspirate4, After numerous attempts to get it working in different operating systems : Linux/Windows/Mac os x, I have come to the conclusion that it is defective/faulty.

I am unable to upgrade the firmware as well.
unable to do so, it complains about connecting to the "Bootloader" and i have put the device in to boot loader mode successfully.? please advise me anything I could do?


Thank you[/quote]

Why you just cant update your firmware to the latest version?
viewtopic.php?f=28&t=8498
http://dangerousprototypes.com/docs/Bus ... _Pirate_v4
Your BusPirate v4 will be a very reliable tool after this update