Skip to main content
Topic: 0.9.6.1 Runs, 0.9.7 run.bat Stalls (Read 9230 times) previous topic - next topic

0.9.6.1 Runs, 0.9.7 run.bat Stalls

I ordered an Open Workbench Logic Sniffer today and thought I would get a head start looking at the software.  I downloaded the latest version of the client ols-0.9.7.  When I run the "run.bat" file a terminal window opens, the following lines scroll, and then nothing more, the terminal window is frozen.

I downloaded 0.9.6.1, and it runs fine.  Any suggestions on why 0.9.7 may not be working?

I am running Windows 7 Professional 64bit, SP1 on a Dell Precision T3500, with 6GB of ram.

Re: 0.9.6.1 Runs, 0.9.7 run.bat Stalls

Reply #1
Hard to determine without any additional information, could you post the lines of the terminal when running version 0.9.7?
when good software is not an alternative...

Re: 0.9.6.1 Runs, 0.9.7 run.bat Stalls

Reply #2
Sorry.  I meant to post it in my original message.

Unfortunately the forum software won't let me include the terminal text, wrapped or plain, because it thinks its URL's for some reason and that I am a spammer.  I also tried linking to a screen capture, but of course that actually was a URL and I got tagged as spam for that as well.

Descriptively with periods replaced with DOT:

line 1 - Feb 20, 2014 7:44:06 PM nlDOTlxtremeDOTolsDOTrunnerDOTRunner <init>
line 2 - INFO: Bootstrap complete . . .
line 3 - same as line 1
line 4 - INFO: plugin dir: <path to the plugins directory>

Then it just freezes no cursor in the DOS console.

Re: 0.9.6.1 Runs, 0.9.7 run.bat Stalls

Reply #3
Hi!
Did you  fixed your  problem because i  have the same? After the first run of run.bat the cmd window stall. And after the second run i  have plenty of  error messages  :  ERROR: Bundle nl.lxtreme.ols.client.project [32] Error starting file:/C:/I2CSPY/
plugins/client.project-1.0.0.jar (org.osgi.framework.BundleException: Unresolved
 constraint in bundle nl.lxtreme.ols.client.project [32]: Unable to resolve 32.0
: missing requirement [32.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtr
eme.ols.api)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 6... etc....

Any  solution???

Thanks!

Re: 0.9.6.1 Runs, 0.9.7 run.bat Stalls

Reply #4
Same problem here. Win7 64 Dell M4800. Newest Java and Java SE installed.

I do not have a clue what is wrong or where to go...

Run.bat replies:

Code: [Select]
ERROR: Bundle nl.lxtreme.ols.tool.serialconsole [4] Error starting file:/C:/Program%20Files/OpenSnif/plugins/serialconsole-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.serialconsole [4]: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api.data.annotation)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
ERROR: Bundle nl.lxtreme.ols.device.logicsniffer [5] Error starting file:/C:/Program%20Files/OpenSnif/plugins/logicsniffer-1.1.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.device.logicsniffer [5]: Unable to resolve 5.0: missing requirement [5.0] osgi.wiring.package; (osgi.wiring.package=javax.swing.border))
ERROR: Bundle nl.lxtreme.ols.tool.linedecoder [6] Error starting file:/C:/Program%20Files/OpenSnif/plugins/linedecoder-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.linedecoder [6]: Unable to resolve 6.0: missing requirement [6.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
ERROR: Bundle nl.lxtreme.ols.client [7] Error starting file:/C:/Program%20Files/OpenSnif/plugins/client-1.2.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.client [7]: Unable to resolve 7.0: missing requirement [7.0] osgi.wiring.package; (osgi.wiring.package=javax.swing.border))
ERROR: Bundle nl.lxtreme.ols.tool.uart [8] Error starting file:/C:/Program%20Files/OpenSnif/plugins/uart-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.uart [8]: Unable to resolve 8.0: missing requirement [8.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
ERROR: Bundle nl.lxtreme.ols.tool.dmx512 [9] Error starting file:/C:/Program%20Files/OpenSnif/plugins/dmx512-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.dmx512 [9]: Unable to resolve 9.0: missing requirement [9.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
ERROR: Bundle nl.lxtreme.ols.tool.spi [10] Error starting file:/C:/Program%20Files/OpenSnif/plugins/spi-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.spi [10]: Unable to resolve 10.0: missing requirement [10.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
ERROR: Bundle nl.lxtreme.ols.tool.state [11] Error starting file:/C:/Program%20Files/OpenSnif/plugins/state-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.state [11]: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; (osgi.wiring.package=javax.swing.border))
ERROR: Bundle nl.lxtreme.ols.tool.jtag [12] Error starting file:/C:/Program%20Files/OpenSnif/plugins/jtag-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.jtag [12]: Unable to resolve 12.0: missing requirement [12.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
ERROR: Bundle nl.lxtreme.ols.export.image [13] Error starting file:/C:/Program%20Files/OpenSnif/plugins/image-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.export.image [13]: Unable to resolve 13.0: missing requirement [13.0] osgi.wiring.package; (osgi.wiring.package=javax.imageio))
ERROR: Bundle nl.lxtreme.ols.util [14] Error starting file:/C:/Program%20Files/OpenSnif/plugins/util-1.1.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.util [14]: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility))
ERROR: Bundle nl.lxtreme.ols.export.vcd [15] Error starting file:/C:/Program%20Files/OpenSnif/plugins/vcd-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.export.vcd [15]: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api.acquisition)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
ERROR: Bundle nl.lxtreme.ols.service.taskexecution [17] Error starting file:/C:/Program%20Files/OpenSnif/plugins/service.taskexecution-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.service.taskexecution [17]: Unable to resolve 17.0: missing requirement [17.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api.task)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
ERROR: Bundle nl.lxtreme.ols.tool.base [19] Error starting file:/C:/Program%20Files/OpenSnif/plugins/base-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.base [19]: Unable to resolve 19.0: missing requirement [19.0] osgi.wiring.package; (osgi.wiring.package=javax.swing.filechooser))
ERROR: Bundle nl.lxtreme.ols.service.acquisition [20] Error starting file:/C:/Program%20Files/OpenSnif/plugins/service.acquisition-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.service.acquisition [20]: Unable to resolve 20.0: missing requirement [20.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
ERROR: Bundle nl.lxtreme.ols.tool.i2c [22] Error starting file:/C:/Program%20Files/OpenSnif/plugins/i2c-1.0.1.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.i2c [22]: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
ERROR: Bundle nl.lxtreme.ols.device.test [23] Error starting file:/C:/Program%20Files/OpenSnif/plugins/test-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.device.test [23]: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (osgi.wiring.package=javax.swing.border))
ERROR: Bundle nl.lxtreme.ols.api [24] Error starting file:/C:/Program%20Files/OpenSnif/plugins/api-1.0.5.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.api [24]: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)])
ERROR: Bundle nl.lxtreme.ols.tool.asm45 [25] Error starting file:/C:/Program%20Files/OpenSnif/plugins/asm45-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.asm45 [25]: Unable to resolve 25.0: missing requirement [25.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
ERROR: Bundle nl.lxtreme.ols.tool.1wire [26] Error starting file:/C:/Program%20Files/OpenSnif/plugins/1wire-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.tool.1wire [26]: Unable to resolve 26.0: missing requirement [26.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
ERROR: Bundle nl.lxtreme.ols.device.generic [27] Error starting file:/C:/Program%20Files/OpenSnif/plugins/generic-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.device.generic [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
ERROR: Bundle nl.lxtreme.ols.export.csv [29] Error starting file:/C:/Program%20Files/OpenSnif/plugins/csv-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.export.csv [29]: Unable to resolve 29.0: missing requirement [29.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api.acquisition)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
ERROR: Bundle nl.lxtreme.ols.client.project [31] Error starting file:/C:/Program%20Files/OpenSnif/plugins/client.project-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.client.project [31]: Unable to resolve 31.0: missing requirement [31.0] osgi.wiring.package; (&(osgi.wiring.package=nl.lxtreme.ols.api)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (osgi.wiring.package=nl.lxtreme.ols.util) [caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)]])
ERROR: Bundle nl.lxtreme.ols.lib.mydoggy [33] Error starting file:/C:/Program%20Files/OpenSnif/plugins/lib.mydoggy-1.5.0-SNAPSHOT.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle nl.lxtreme.ols.lib.mydoggy [33]: Unable to resolve 33.0: missing requirement [33.0] osgi.wiring.package; (osgi.wiring.package=javax.accessibility)) 

Re: 0.9.6.1 Runs, 0.9.7 run.bat Stalls

Reply #5
I just tried 0.9.6 as well. Same problem.

Do I need the JDK?

Should I get Java 7 instead of 8?

Jawi, thank you for your efforts on this software and support. It looks so promising, that I have spend hours getting the software to run. Unfortunately with little success so far...

Re: 0.9.6.1 Runs, 0.9.7 run.bat Stalls - Solved

Reply #6
My collegue has a Dell PC win 7 64, where the software runs fine. Our Windows are both 6.1.7601.
His cmd(java - version) = 1.7.0_51b13 (Working)
My cmd(java - version) = 1.8.0_11b12 (Not working)
I downgraded to 1.7.0_67-b01. Now it works.

Conclusion: OLS does not work on my computer with Java ver 8 but runs with Java ver. 7.

I suggest making a remark in the FAQ:
https://github.com/jawi/ols/wiki/FAQ
which lead me to installing Java 8.

Re: 0.9.6.1 Runs, 0.9.7 run.bat Stalls

Reply #7
Hi Johnny !

Thank you  very  much..  it works fine now w/ 1.7.0_51!!

Now i have to learn how to install various versions of  Java on my PC :(((

Re: 0.9.6.1 Runs, 0.9.7 run.bat Stalls

Reply #8
I got into the same problem ,  when I installed Java jre 8 has the std jre  I was not able to start the client window.  I had to unistall and reinstall latest 1.7.x .

Re: 0.9.6.1 Runs, 0.9.7 run.bat Stalls

Reply #9
I've made some changes in a separate branch to resolve the issues with JDK 1.8. Needs some additional testing prior to cutting a new release...
when good software is not an alternative...

Re: 0.9.6.1 Runs, 0.9.7 run.bat Stalls

Reply #10
I tested the latest 0.9.7.1 branch version and placed some comments with results on ticket #211 for this issue.

I would help more by figuring out what the problems are in code, but my efforts are stopped by my lack of knowledge on the  OSGi framework or Felix, unfortunately. That being said, I'll try my best to make sure that I can use the latest OLS version for my logic sniffer from seeed, if it arrives :-)

-edit- Latest 0.9.7.1 version now seems to work with Java 1.8 on windows! Thanks to some awesome work done by jawi.

Re: 0.9.6.1 Runs, 0.9.7 run.bat Stalls

Reply #11
Thanks for testing it out, ggvw! I've made a new release that should solve this issue, see http://ols.lxtreme.nl/ for download links...
when good software is not an alternative...

Re: 0.9.6.1 Runs, 0.9.7 run.bat Stalls

Reply #12
Thanks a lot it works fine now!!
Best Regards