Skip to main content
Topic: Lcd adapter issue ! (Read 2375 times) previous topic - next topic

Lcd adapter issue !

Hello all, im new here and am struggling a bit to get things going.
First i did choose to assembly my own adapter simply cause i lucked up by have the correct chip on hand. im not sure tera term is completely setup i only choose baud and proper com port i can turn on and of the lcd back light but that it i am sure the bp is connected and responding but i am getting no text on lcd. any help would be great !

Re: Lcd adapter issue !

Reply #1
i also notice i have no blinking curser and my 2x16 display only block fills the bottom.

Re: Lcd adapter issue !

Reply #2
Can you paste the terminal output of what you tried?
Got a question? Please ask in the forum for the fastest answers.

Re: Lcd adapter issue !

Reply #3
Also please tell us how the things are connected to the lcd and buspirate.

Re: Lcd adapter issue !

Reply #4
Thanks for the response !
    i made my own ribbon cables from ide cable and a some ten pin connectors i picked up from e-store i must have watched Dave's video 6 or 7 times to get oritation for the cable
 "simple"

 by the way THUMBS UP 2 Ian ! for not allowing us newbs to destroy our stuff by plugging them in wrong !!!
 The bus pirate is connected via ribbon cable .
 
Too Ian, i only I am a total newb ! this is the first time running a terminal program but i have used other programs to flash and edit things so i'm capable just not sure if setting proper comm port and buad rate is the only thing need to configure the bus pirate and tera term to work properly. i did only the stuff i seen in your video on the website for the lcd adapter. Now the omition i am not using the 0.1 cap between voltage and ground because i can find one but i noticed you did use one in a few of the breadboard setups so i just gave it a go without till my mouser gets in. also my chip is nxp 74hc595n .

Re: Lcd adapter issue !

Reply #5
Had sometime to myself minus the noise to look ouver my scratch built lcd adapter. in my haste to finish i missed to key connections ! after hour or so of tracing things down i have a working adapater !

 

Re: Lcd adapter issue !

Reply #6
[quote author="Somehack"]Had sometime to myself minus the noise to look ouver my scratch built lcd adapter. in my haste to finish i missed to key connections ! after hour or so of tracing things down i have a working adapater ![/quote]

Great to hear you got it working, share any pics.
best regards FIlip.

Re: Lcd adapter issue !

Reply #7
Sorry i just stopped in to see what's going on. yeah this puppy work's fine when i fudge a few things i was bumbbed ! i also had no luck with a voltage reg circuit i was building i figured i was washed up !! but after some checking the old fart at the electronic supply gave me a nte966 NOT the 956 i ask for !!!! so once i caught the prob, i got back on the adapter and found my booboo and everything's been great !!!!!