Skip to main content
Topic: BusBlaster + Openocd + SAM7-P256 + OS X (Read 6916 times) previous topic - next topic

BusBlaster + Openocd + SAM7-P256 + OS X

Hello,

I'm new in ARM processors and i'm trying to program SAM7-P256 (Olimex board with AT91SAM7S256) using Bus Blaster as a Jtag interface.

I have successfully installed FTDI D2XX drivers as well as OpenOCD on OS X, but when i run OpenOCD i get the following output.

Code: [Select]
$openocd -f tcl/interface/busblaster.cfg -f tcl/target/at91sam7x256.cfg 

Open On-Chip Debugger 0.8.0-dev-00011-g70a2ffa (2013-05-13-12:15)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.sourceforge.net/doc/doxygen/bugs.html
Info : only one transport option; autoselect 'jtag'
DEPRECATED! use 'adapter_khz' not 'jtag_khz'
adapter speed: 2000 kHz
srst_only srst_pulls_trst srst_gates_jtag srst_open_drain connect_deassert_srst
Info : device: 6 "2232H"
Info : deviceID: 67330064
Info : SerialNumber:
Info : Description: Dual RS232-HS A
Info : max TCK change to: 30000 kHz
Info : clock speed 2000 kHz
Info : TAP sam7x256.cpu does not have IDCODE
Warn : JTAG tap: sam7x256.cpu      UNEXPECTED: 0x00000000 (mfg: 0x000, part: 0x0000, ver: 0x0)
Error: JTAG tap: sam7x256.cpu  expected 1 of 1: 0x3f0f0f0f (mfg: 0x787, part: 0xf0f0, ver: 0x3)
Warn : Unexpected idcode after end of chain: 1 0xfffffffe
Error: double-check your JTAG setup (interface, speed, missing TAPs, ...)
Error: Trying to use configured scan chain anyway...
Error: sam7x256.cpu: IR capture error; saw 0x0f not 0x01
Warn : Bypassing JTAG setup events due to errors
Info : Embedded ICE version 0
Error: unknown EmbeddedICE version (comms ctrl: 0x00000000)
Info : sam7x256.cpu: hardware has 2 breakpoint/watchpoint units

The SAM7-P256 is connected to BusBlaster using a ribbon cable and both boards are powered via USB.

Here is a photo:

Re: BusBlaster + Openocd + SAM7-P256 + OS X

Reply #1
After a lot of search i decided to reprogram the CPLD in order to make sure that it is programmed with Jtagkey.

So i followed the instruction shown here http://dangerousprototypes.com/docs/Bus ... rogramming

at the third step :
Code: [Select]
jtag> detect
IR length: 8
Chain length: 1
Device Id: 00000110111000011100000010010011 (0x06E1C093)
Filename:    c:/bsdl/xc2c32a_vq44.bsd
jtag>

i get this:

Code: [Select]
jtag> detect
Warning: TDO seems to be stuck at 1
jtag> detect
Warning: TDO seems to be stuck at 1

Note that Jtag (2x10) cable is unplugged.
The BusBlaster is only connected to a usb cable.
Also Jp4 isn't connected.
BusBlaster version 2.5

Here is a logic analyzer look of the 2x10 Jtag Pins

Re: BusBlaster + Openocd + SAM7-P256 + OS X

Reply #2
Today i tried connecting the same Busblaster on a windows machine.

To be more specific
I have install D2XX drivers : http://www.ftdichip.com/Drivers/CDM/CDM20828_Setup.exe
I have also install urjtag : http://sourceforge.net/projects/urjtag/ ... e/download

The output is the same for any interface i tried.
Code: [Select]
jtag> cable ft2232 interface=0
Connected to libftd2xx driver.
jtag> detect
Warning: TDO seems to be stuck at 1
jtag> cable ft2232 interface=1
Connected to libftd2xx driver.
jtag> detect
Warning: TDO seems to be stuck at 1
jtag> cable ft2232 interface=2
Connected to libftd2xx driver.
jtag> detect
Warning: TDO seems to be stuck at 1

I have the same ouptut on OS X.

I tried connecting my Logic Αnalyzer on the side header to watch the output signal of Jtag in each interface selection but no signals are detected. Pins TDO,TDI,TCK and TMS are held always high

Re: BusBlaster + Openocd + SAM7-P256 + OS X

Reply #3
I now noticed that in Bus Blaster buffer logic urJTAG How To says

Quote
Download the CPLD buffer bitstream (and patched urJTAG):
So i downloaded and copied the patched urJTAG as described.

Now i get the following error:

Code: [Select]
jtag> cable ft2232 interface=1
Couldn't connect to suitable USB device.
Error: usbconn/libftd2xx.c:406 usbconn_ftd2xx_common_open() ftdi/ftd2xx error: U
nable to open TFDI device: device not found

Re: BusBlaster + Openocd + SAM7-P256 + OS X

Reply #4
Did you make any progress? Has anyone actually had success with the busblaster + SAM7-P256?

I have an Olimex arm-usb-tiny-h (also ft2232 based) which works fine (using the appropriate openocd config, of course). Just replacing the arm-usb-tiny-h with my newly aquired busblaster v2.5 (using the bus blaster openocd config instead) results in some error messages.

Both under Linux using the exact same setup except the jptag adaptors.

 

Re: BusBlaster + Openocd + SAM7-P256 + OS X

Reply #5
You're obviously going through a methodical process to identify where the issues lie, which is good. You've been able to identify that you haven't managed to write the bitstream to the Bus Blaster, so attempting connection with the SAM7-P256 isn't going to work, as you've noted. I have had success with connecting to both SAM7-S256 and BCM6368 parts for example. I haven't yet broken out OpenOCD to find out what's going on, but it's on my list.

I have experienced issues when I've had multiple FTDI serial devices connected to the system. It seems that urjtag will assume that any FTDI serial device is a potential JTAG adapter. Hence, if I had my USB to serial converter connected, all my interfaces are shifted up one, which means I need to adjust my "interface=" parameter. If I have a couple of USB to serial converters as well as the Bus Blaster connected, I have to tell urjtag to use "cable ft2232 interface=3"