Skip to main content
Topic: Change to Twitter, Twatch no longer working? (Read 30461 times) previous topic - next topic

Re: Change to Twitter, Twatch no longer working?

Reply #15
Hi all,

just to let you know I have an original Twatch from the first batch from seed.

I did the update a minute ago and it works perfectly. (using the twatchv2-v0e firmware)

Thank you :)

Re: Change to Twitter, Twatch no longer working?

Reply #16
Thanks for the update. Glad you got it working :)
Got a question? Please ask in the forum for the fastest answers.

Re: Change to Twitter, Twatch no longer working?

Reply #17
Same problem here.
After booting the #twatch on line 2 the message:      Error reconnecting, Error, waiting 5 min.
Twatch.source.r1214.v2b.zip  installed but the problem not solved. 
No Twitter.

Version 2

The APP iTwatch works great.
So no hardware problem.

Cheers

Re: Change to Twitter, Twatch no longer working?

Reply #18
unit started acting up again the other day just about the same symptoms any ideas?
p.s. I usually leave unit on  24/7

Re: Change to Twitter, Twatch no longer working?

Reply #19
Thanks for the report, I'll try to figure it out and release an update.
Got a question? Please ask in the forum for the fastest answers.

Re: Change to Twitter, Twatch no longer working?

Reply #20
Looks like the GET trends method is deprecated. Now we need to feed from:
api.twitter.com/1/trends/1.json

https://dev.twitter.com/docs/api/1/get/trends/%3Awoeid

Hopefully it is a drop-in replacement.
Got a question? Please ask in the forum for the fastest answers.

Re: Change to Twitter, Twatch no longer working?

Reply #21
Don't understand what you said but if it fixes it, I hope it works too.

 

Re: Change to Twitter, Twatch no longer working?

Reply #22
Sorry this took so long, there was some other debugging needed too. This is v0f, works well on my twatch.

The twatch stopped working because Twitter disabled the feed we used to grab the current trending topics:
http://api.twitter.com/1/trends/current.json

and changed to a feed that can be limited by Yahoo! Where On Earth region IDs. We want worldwide trending topics, so we set the region to 1:
http://api.twitter.com/1/trends/1.json

Additionally, there was a minor change in feed format that put the region into the trend results. This was fixed by modifying the search keys.

The update instructions are here, a .bat file is included in the firmware to save you some typing. Latest source is in SVN.
http://dangerousprototypes.com/docs/Net ... _procedure

Also available at google code: http://code.google.com/p/dangerous-prot ... rmware.zip
Got a question? Please ask in the forum for the fastest answers.

Re: Change to Twitter, Twatch no longer working?

Reply #23
I have it running here.  Though I'm not much into Twitter, it's an interesting application and I'm looking forward to reading your most recent source to get ideas for my own project.

Re: Change to Twitter, Twatch no longer working?

Reply #24
Just dug my #twatch out of a box and hooked it up, didn't work. I updated to the v0f firmware and it is still showing "*Error, waiting 5min" then it tries to reconnect and rolls back to the same message. The LCD is lit by default now so I know the firmware got applied. It has a valid IP and responds to ping.

 Did the api feed change again? Can someone work up a fix?

Re: Change to Twitter, Twatch no longer working?

Reply #25
I am unaware of any changes. If anyone knows the cause I can try to update it.
Got a question? Please ask in the forum for the fastest answers.

Re: Change to Twitter, Twatch no longer working?

Reply #26
If you are not aware of any changes perhaps the issue is on my end. I will do some testing tonight maybe my firewall is causing issues.

Thanks for the quick reply to this forums full of dusty posts.