Skip to main content
Topic: Problems connecting to Bus Pirate (Read 5988 times) previous topic - next topic

Problems connecting to Bus Pirate

Hi everyone,

I just received my Bus Pirate today. The problem is that when I plug in the usb cable windows just says unrecognized hardware found and the on board USB-led is lit very faint... The USB led lights up very briefly when I insert the USB cable. The power led lights up just fine.

Could this be a problem with the FTDI chip or ?

Re: Problems connecting to Bus Pirate

Reply #1
Everything sounds fine. Did you install the FTDI driver? Check out my Bus Pirate 101 post:
http://dangerousprototypes.com/2009/07/ ... irate-101/

If you canceled it once in the past you may need to go to the control panel, click the unknown device, and click 'reinstall driver'.
Got a question? Please ask in the forum for the fastest answers.

Re: Problems connecting to Bus Pirate

Reply #2
Yeah I did that - also have a couple of Arduinos running just fine.

Re: Problems connecting to Bus Pirate

Reply #3
Just been trying again - Windows tells me that the USB device has malfunctioned. If the Bus Pirate is dead - who would I contact to get it replaced?

Re: Problems connecting to Bus Pirate

Reply #4
The problem would seem to be the FTDI chip - I just tried bypassing it using the rx/tx lines and a max232 breakout board and I seem to be getting some of the menu.

Not too sure what to do from here though - is there any sort of warranty covering a bad ftdi chip or?

Re: Problems connecting to Bus Pirate

Reply #5
You're going to have to contact Hack a Day and/or Seeed to see what the policy is, I'm not with Hack a Day anymore.

I know that Seeed did two tests on each unit before shipping: bootloader and terminal, so it probably left in good shape, but damage during shipping could be a possibility.
Got a question? Please ask in the forum for the fastest answers.

Re: Problems connecting to Bus Pirate

Reply #6
I just got in contact with Seeed - they want me to ship it back to them.

Thank you for the quick replies.

Re: Problems connecting to Bus Pirate

Reply #7
I'm sorry your Bus Pirate didn't work. I wish I could be more help. Let me know when you get the replacement.
Got a question? Please ask in the forum for the fastest answers.

Re: Problems connecting to Bus Pirate

Reply #8
Just sent it - will let you know when I get it back.

Re: Problems connecting to Bus Pirate

Reply #9
I received a replacement Bus Pirate from Seeed Studio today - just upgraded it to v2 :)

Re: Problems connecting to Bus Pirate

Reply #10
Be sure to grab the latest 2.1-RC2 (or RC3 in the nightly), tons of bug fix update goodness.
Got a question? Please ask in the forum for the fastest answers.