Skip to main content
Topic: Bus Pirate V4 hang on power on (Read 183 times) previous topic - next topic

Bus Pirate V4 hang on power on

Hello

I connect a I2C bus device (RTC) just to the powerlines (3V3 and 5V tested) from the Bus Pirate, select i2c, hardware, 400khz and switch then the power on. After the last step the BP hangs. I have tried 20 times, always the same.
With my Bus Pirate 3.6 this works as expected. The RTC consumes 2mA !!! but it look as was the power shortened but there is not shortage.
Any idea ?

PS: If i connect nothing to the BP, i can switch on without an hang, but as soon as i connect the RTC, the BP hangs again

Regards

Re: Bus Pirate V4 hang on power on

Reply #1
It may be a bad voltage regulator, it sounds like BP is browning out and USB communication is getting terminated.

What voltage level are you using? Maybe you can connect a resistor to test it out? Or do you have a voltmeter to measure the voltage on the output pins when BP hangs?

Re: Bus Pirate V4 hang on power on

Reply #2
Hello

Thanks for the quick reply.
If nothing is connected i get 5V and 3,3V. As soon as i connect an I2C device, ther is 0 Volts and BP hangs on power-on. The led of the I2C device blinks very short, but thats it. Also i noticed that the USB name changes some times from \USBSER000 to \USBSER001.
If i use an external power source all works fine. Only the internal power-source of the Bus Pirate seems to be dead.
I also tried on another USB Port, but if BP 3.6 works, all must be fine.
Is there anyting else i can do, or just call the vendor for a refund ?

Regards

Re: Bus Pirate V4 hang on power on

Reply #3
Actually my bad, when BP hangs, power pins should be off, it's kinda expected.

There's not much you can do unless you want to figure out which voltage regulator is bad and replace it with a new one. At this point it seems like refund is your best option.

There may be another problem like some short to ground or something else but they're hard to debug without me having access to the device.