Skip to main content
Topic: Reviving a Bus Pirate 3.6 (Read 104 times) previous topic - next topic

Reviving a Bus Pirate 3.6

Hi,

Just today I connected my Bus Pirate (3.6)  again after a long time, and after figuring out how it should work, had to conclude it doesn't. I bought it in 2014 and it worked then. Now it doesn't respond to terminal input (no response and USB LED doesn't blink). I also tested this with a FT232R Breakout board and it does respond with blinking. So the USB-serial is working.

The only time the Bus Pirate responds is when I put it in programming mode (connect PGC and PGD, which lights the MODE-LED). It responds with "BL4+" and an USB LED blink for every key stroke. So I conclude it is not completely dead, maybe just in some non-communitative mode.

Might re-programming work? Is BL4+ the normal bootloader response?

Thanks in advance,

Fred Jan

 

Re: Reviving a Bus Pirate 3.6

Reply #1
More or less fixed it myself with help from the FAQ.

Managed to get a pirate-loader to upload a more recent firmware, and although it says failed, I now have a prompt on terminal mode.

Thanks for the great FAQ!

Still wondering what the different optX versions are, but maybe more RTFM will help here too.

Greetings,

Fred Jan

Code: [Select]
BusPirate$ ./pirate-loader --dev=/dev/ttyUSB0 --hex=bpv3_fw7.0_opt0_18092016.hex
+++++++++++++++++++++++++++++++++++++++++++
  Pirate-Loader for BP with Bootloader v4+ 
  Loader version: 1.0.2  OS: UNKNOWN
+++++++++++++++++++++++++++++++++++++++++++

Parsing HEX file [bpv3_fw7.0_opt0_18092016.hex]
Found 18579 words (55737 bytes)
Fixing bootloader/userprogram jumps
Opening serial device /dev/ttyUSB0...OK
Configuring serial port settings...OK
Sending Hello to the Bootloader...OK

Device ID: PIC24FJ64GA002 [d4]
Bootloader version: 1,02
Erasing page 0, 0000...OK
....
Writing page 41 row 333, a680...OK
Writing page 41 row 334, a700...OK
Writing page 41 row 335, a780...OK
Erasing page 42, a800...ERROR [50]

Error updating firmware :(
BusPirate$