Skip to main content
Topic: USB Infrared Toy with WINLIRC (Read 1056 times) previous topic - next topic

USB Infrared Toy with WINLIRC

Hi All

I am having problems with WinLIRC (version 0.9.0) in that it refuses to proceed once I have set up the USB Infrared Toy.

My USB Infrared Toy has been updated to the latest firmware (V22), and is configured to COM Port 5.  I am using the IRToy.dll file.

I can run the WinLIRC application on first use, opt to use COM5 and run the config set up (see below), so the software and the USB Infrared Toy are clearly communicating. Config shows the following:

# this config file was automatically generated
# using lirc-0.9.0(IRToy) on Sun Nov 10 15:37:56 2019
# contributed by
# brand:                       ..\
# model no. of remote control:
# devices being controlled by this remote:

begin remote

  name  ..\
  bits           15
  eps            30
  aeps          100

  one           247  1828
  zero          247   774
  ptrail        247
  gap          66819
  toggle_bit_mask 0x0

      begin codes
          Power                    0x41A2 0x425D
      end codes

end remote

However, once I have completed this process, the application shuts down and then refuses to open.   I have tried different ports, different configs - I still get the same result.

Rather infuriating, as I would like to record the "Power" button on a remote to auto turn on using the USB Infrared Toy for a project I am working on.   It's quite an old CRT TV that doesn't have auto power on with signal capability, and this was my planned workaround.  At the moment I have hit this dead end.

I tried to run the software with a diagnostic switch, but can't get it to run via the exe or even running through Command Prompt as administrator.

Hope someone can help!

Kind regards,