Skip to main content
Topic: XSVF Player with Xilinx Spartan 6 XSVF_ERROR_DATAOVERFLOW (Read 424 times) previous topic - next topic

XSVF Player with Xilinx Spartan 6 XSVF_ERROR_DATAOVERFLOW

Hello,

I am trying to use my bus pirate v3.6 with the xsvf player firmware, to program my Xilinx Spartan 6 FPGA with a .xsvf file created with Xilinx ISE / iMPACT.

This is the output when I try to send the .xsvf

Code: [Select]
.BPXSVFplayer.exe -p COM3 -f .default.xsvf
-----------------------------------------------------------------------------

 BusPirate XSVF Player V.01

-----------------------------------------------------------------------------
File is 343424 bytes, read 343424 bytes Opening Bus Pirate on COM3 at 115200bps, using XSVF file .default.xsvf
 Entering XSVF Player Mode
 Waiting for first data request...ok
Sending 4096 Bytes (1000)...ok
End of operation reply 06
  Error, data overflow: XSVF_ERROR_DATAOVERFLOW
 Thank you for Playing! :-)

The FPGA is recognised though, as you can see in the JTAG boundary scan (the -x option)

Code: [Select]
.BPXSVFplayer.exe -x -p COM3
-----------------------------------------------------------------------------

 BusPirate XSVF Player V.01

-----------------------------------------------------------------------------
 Performing Chain Scan..
 Waiting for a chain scan reply
 Chain Scan Result: 04 93 10 00 24

 No file specified. Need an input xsvf file

The only "clue" I found is this old post in this forum:
http://http://dangerousprototypes.com/forum/viewtopic.php?f=4&t=5715&view=next
The person solved it resynthetizing, maybe because his/her .xsvf file was not correct. That hasn't worked for me so far.

My FPGA is a clonic Xilinx X-SP6-X9 XC6SLX9 TQG144 with speed 2 (-2). I use ISE 14.7 on win10 and also tested on the Red Hat Server VM (same result).

I don't use iMPACT to directly flash the FPGA as I don't have a Xilinx cable but the Bus Pirate.

Anyone knows what could be the issue?

Thanks