Dangerous Prototypes

Other projects => Open Bench Logic Sniffer => Client software => Topic started by: Jean on November 05, 2015, 09:08:16 am

Title: Frozen client after capture launch - Ubuntu 14.04
Post by: Jean on November 05, 2015, 09:08:16 am
Hello.

I had installed client 0.9.7.2 on my system Ubuntu 14.04. Unpacked files was OK in a directory where user can be work on files.
Launch software is OK with run.sh
I can work with File menu, Diagram menu (2 items), Tools menu and him serial console, and help menu.
But when i launch capture, software froze and commands don’t work. I must quit client bye kill command.
command Edit/Preference make same.

OpenBench Logic Sniffer is sélect in Capture Device menu and seems have a good work.
When i connect OpenBench Logic Sniffer, i see them on /dev/ttyACM0.
When i launch Tools/Console, communication is OK between software and hardware ( radio FM is perturbed !!!).

Client is in "plugdev" group and the user is in this group ( by adduser command).
ls -l command results :
   total 45
-rwxrwx--- 1    root    plugdev  224       nov.  4 08:57 AUTHOR
drwxrwx--- 1    root    plugdev    0       nov.  4 08:57 bin
-rwxrwx--- 1    root    plugdev  2936    nov.  4 08:57 CHANGELOG
-rwxrwx--- 1    root    plugdev 18433    nov.  4 08:57 LICENSE
drwxrwx--- 1    root    plugdev  8192    nov.  4 08:57 plugins
-rwxrwx--- 1    root    plugdev  423       nov.  4 16:03 Projet_1.olp
-rwxrwx--- 1    root    plugdev  3615    nov.  4 08:57 README
-rwxrwx--- 1    root    plugdev  1338    nov.  4 08:57 run.bat
-rwxrwx--- 1    root    plugdev  1462    nov.  4 18:20 run.sh [/code]

It's the first time i try to use OpenBench Logic Sniffer and Client and probably buy Pirate bus.

So, i don't know where is problem and spend my time two days !!!!

NB : when connecting OpenBench Logic Sniffer, her PWR and TRIG LED are ON (light).

Thank you for help.
Jean
Title: Re: Frozen client after capture launch - Ubuntu 14.04
Post by: Jean on November 11, 2015, 07:27:36 pm
I just read that Ubuntu don't use Java version Oracle but OpenJDK (problem of GPL ).

Is it source of my problems ?
Title: Re: Frozen client after capture launch - Ubuntu 14.04
Post by: Jean on November 11, 2015, 07:47:46 pm
... and when i use Tools/Serial console with ttyACM0 in serial port, send a message to OpenBench Logic Sniffer make the transmiting led blink on the hardware ...
Title: Re: Frozen client after capture launch - Ubuntu 14.04
Post by: Jean on November 23, 2015, 07:49:21 pm
It's seems that this forum is frozen ... as my screen !
Today, i had tryed Linux MINT 17-2 on a usb disk, with my same notebook. As Ubuntu 14.04, Mint use OpenJDK.
Naturally, after good use of Mint, i had connected my openbench logic sniffer with ols 0.9.7.2 and ... he work !

I did n't understood why, but it's good ... now.

Have, somebody witch use OLS 0.9.7.2 with Ubuntu 14.04  64 bits in EFI mode ?
Title: Re: Frozen client after capture launch - Ubuntu 14.04
Post by: jawi on November 24, 2015, 05:23:46 pm
Hmm, it seems the notifications from this forum are not working for me any longer... Anyway, not sure what might be causing the freeze. I did test the 0.9.7.2 release on Ubuntu (14.04 IIRC, not sure if it was 32 or 64 bit), and did not experience any freezes. Given that your OBLS is working with Mint Linux, it rules out any hardware issues, so that is not the cause. So, I'm not sure what might be the cause of the problems using Ubuntu. Are you able to share some additional information of your Ubuntu installation, like Java version, etc.?
Title: Re: Frozen client after capture launch - Ubuntu 14.04
Post by: Jean on November 24, 2015, 06:31:47 pm
Hello, Jawi's

Nice to read you and thank you for your answer.
Yes, i've résults of java's version for my two configurations :

Ubuntu 14.04.3 :
~$ java -version
java version "1.7.0_79"
OpenJDK Runtime Environment (IcedTea 2.5.6) (7u79-2.5.6-0ubuntu1.14.04.1)
OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)

Mint 17.2
~ $ java -version
java version "1.7.0_79"
OpenJDK Runtime Environment (IcedTea 2.5.5) (7u79-2.5.5-0ubuntu0.14.04.2)
OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)

Differences aren't big ...
For your information, my problem, now, become non critical : i can use ols !!!
Title: Re: Frozen client after capture launch - Ubuntu 14.04
Post by: Jean on November 28, 2015, 08:02:16 pm
As Jawi said me lest week, i had downloaded ols 0.9.8 and it work good !
my problem, now, is resolved.

thank you very much, Jawi.