Dangerous Prototypes

Other projects => Open Bench Logic Sniffer => Client software => Topic started by: JohnCC on January 25, 2014, 08:22:26 pm

Title: Comboboxes in 0.9.7 don't work with mouse
Post by: JohnCC on January 25, 2014, 08:22:26 pm
First of all, it took me while to find this subforum, my apologies for
contacting the author directly. Here goes the write-up:

In version 0.9.7, the dropdown (combobox) widgets in the capture
dialogs don't work anymore. I mean, they _do_ drop down, but it is
not possible to change the selection. This happens both in the sample
rate setting and in the recording size setting.

I resurrected version 0.9.6, and things are normal there. I can
even set values for both (sample rate and recording size), and
they will then be read in 0.9.7 (but are unchangeable).

After focusing the combobox with a mouse click, it is possible to select
the sample rate (or capture size) with the keyboard. <enter> then
correctly selects the item.

I just noticed that the Color scheme selection combobox _does_
work with the mouse. Not entirely normally though: The dropdown
menu appears at the other end of the OLS window, completely
separate from where the actual Preferences dialog is (8 cm away).

Greetings,
John

Note: I'm using JRE 1.7.0.45 on Slackware Linux
Title: Re: Comboboxes in 0.9.7 don't work with mouse
Post by: jawi on January 27, 2014, 11:30:11 am
I've replied you by email as well, requesting additional information and a possible workaround that might give me some clues as to what the cause of this might be.