Dangerous Prototypes

Other projects => Past projects => #twatch network LCD backpack => Topic started by: Teebor on May 02, 2011, 12:18:29 pm

Title: Change to Twitter, Twatch no longer working?
Post by: Teebor on May 02, 2011, 12:18:29 pm
I've not used my twatch for a while but I turned it on today to find that it cannot connect.  I believe the page trends/current.json which I think it tries to get information from no longer exists/has been changed.

But tbh I don't understand the programming of this at all.

Does anyone know what it should now point to? or have an updated firmware? the last updated firmware I can see in the google code page is from 2009
Title: Re: Change to Twitter, Twatch no longer working?
Post by: ian on May 02, 2011, 12:44:53 pm
We noted this last friday. A new firmware is on the way as soon as we stress test it a bit more.
Title: Re: Change to Twitter, Twatch no longer working?
Post by: Teebor on May 02, 2011, 12:48:32 pm
Thats great, thank you very much :) and thanks for the quick reply.

Sorry if I missed a post about the subject anywhere, I was just worried I was going to have to learn some programming for this, I think my head would explode what with everything else I'm "supposed" to be learning at the moment LOL ;)
Title: Re: Change to Twitter, Twatch no longer working?
Post by: ian on May 03, 2011, 09:56:25 am
This firmware tested for 48 hours without problems. I released a full package and will post about it shortly, but here is just the firmware. Upgrade instructions are here:
http://dangerousprototypes.com/docs/Net ... _procedure (http://dangerousprototypes.com/docs/Network_firmware_update_procedure)

Thanks for reporting on the bug!
Title: Re: Change to Twitter, Twatch no longer working?
Post by: MikeSr39 on May 12, 2011, 06:28:01 am
I did the update and appear to get tweets now, however, I am also getting white pixels in the last two lines of the screen.
is there going to be a fix for that soon??
Or, did I do something wrong???

MikkeSr39
Title: Re: Change to Twitter, Twatch no longer working?
Post by: ian on May 12, 2011, 07:02:06 am
Hi Mike,

I haven't had this problem on my #twatch. The only change I made to the firmware was the Twitter feed address as described here:
http://dangerousprototypes.com/2011/05/ ... pdate-v0e/ (http://dangerousprototypes.com/2011/05/03/twatch-twitter-trends-watcher-firmware-update-v0e/)

Is it possible you can post a picture?
Title: Re: Change to Twitter, Twatch no longer working?
Post by: MikeSr39 on May 12, 2011, 09:04:11 am
don't know  how to add an image, I just took a picture and can't figure out how to post it !!! I tried adding it as an attachment but it says it's the wrong type of attachment. not sure how to do it as an image,sorry.
Title: Re: Change to Twitter, Twatch no longer working?
Post by: ian on May 12, 2011, 09:23:27 am
Sorry about that, you can email it to me at ian@ this site.
Title: Re: Change to Twitter, Twatch no longer working?
Post by: MikeSr39 on May 12, 2011, 09:32:46 am
Sent image via email, hope I got it to the right address.

MikeSr39
Title: Re: Change to Twitter, Twatch no longer working?
Post by: ian on May 12, 2011, 09:37:54 am
Thanks. I see, that is a problem. I will do some testing and try to prepare an alternate firmware for you.

Is this a new #twatch, or did it work previously?
Title: Re: Change to Twitter, Twatch no longer working?
Post by: MikeSr39 on May 12, 2011, 10:09:20 am
worked properly before the changes that made it not work.
as an aside, the white pixels seem to move back and forth on the lines some, don't know if that is any help or not. They move to the left and then back again.

MikeSr39
Title: Re: Change to Twitter, Twatch no longer working?
Post by: ian on May 12, 2011, 03:58:07 pm
Here are two alternate #twatch firmwares. One uses slower updates, it should probably help. The other uses faster updates, it will probably be worse.

Due to the limited number of updates possible with the #twatch, my suggestion is to try the slow update first. If it does now work, then maybe test with the fast version.

Please let me know if this helps.
Title: Re: Change to Twitter, Twatch no longer working?
Post by: MikeSr39 on May 13, 2011, 12:03:40 am
tried slow version and it didn't work, then tried fast version and it still didn't work.
I still have the white pixels in the bottom two lines. information appears to be scrolling by and at the very left hand side I can read it about one pixel at a time but that is all.(One digit???)
Sorry to be all this trouble,but, I really like the unit.

MikeSr39
Title: Re: Change to Twitter, Twatch no longer working?
Post by: MikeSr39 on May 13, 2011, 12:07:41 am
FYI don't know if this makes any difference but the bottom two lines, the 4 digits to the left on each line are clear and I can read information there, but the rest to the right are filled with white pixels(digits???) Letters can be seen in the background moving along but are almost impossible to read.
Title: Re: Change to Twitter, Twatch no longer working?
Post by: ian on May 13, 2011, 08:44:07 am
I'm sorry, I'm afraid I'm out of suggestions. This is the only upgrade related problem reported so far, I'm guessing maybe there is a hardware problem. Please contact Seeed Studio, they can arrange a replacement #twatch. Please keep in mind that the new #twatch will also need to be upgraded, but hopefully without the problems you experienced :)
Title: Re: Change to Twitter, Twatch no longer working?
Post by: rave on June 06, 2011, 02:54:39 pm
Hi all,

just to let you know I have an original Twatch from the first batch from seed.

I did the update a minute ago and it works perfectly. (using the twatchv2-v0e firmware)

Thank you :)
Title: Re: Change to Twitter, Twatch no longer working?
Post by: ian on June 06, 2011, 03:09:39 pm
Thanks for the update. Glad you got it working :)
Title: Re: Change to Twitter, Twatch no longer working?
Post by: wielpirate on October 23, 2011, 12:03:50 am
Same problem here.
After booting the #twatch on line 2 the message:      Error reconnecting, Error, waiting 5 min.
Twatch.source.r1214.v2b.zip  installed but the problem not solved. 
No Twitter.

Version 2

The APP iTwatch works great.
So no hardware problem.

Cheers
Title: Re: Change to Twitter, Twatch no longer working?
Post by: MikeSr39 on October 23, 2011, 03:35:40 am
unit started acting up again the other day just about the same symptoms any ideas?
p.s. I usually leave unit on  24/7
Title: Re: Change to Twitter, Twatch no longer working?
Post by: ian on October 23, 2011, 09:20:01 am
Thanks for the report, I'll try to figure it out and release an update.
Title: Re: Change to Twitter, Twatch no longer working?
Post by: ian on October 23, 2011, 09:34:28 am
Looks like the GET trends method is deprecated. Now we need to feed from:
api.twitter.com/1/trends/1.json

https://dev.twitter.com/docs/api/1/get/trends/%3Awoeid (https://dev.twitter.com/docs/api/1/get/trends/%3Awoeid)

Hopefully it is a drop-in replacement.
Title: Re: Change to Twitter, Twatch no longer working?
Post by: MikeSr39 on October 23, 2011, 09:47:06 am
Don't understand what you said but if it fixes it, I hope it works too.
Title: Re: Change to Twitter, Twatch no longer working?
Post by: ian on November 14, 2011, 04:04:14 pm
Sorry this took so long, there was some other debugging needed too. This is v0f, works well on my twatch.

The twatch stopped working because Twitter disabled the feed we used to grab the current trending topics:
http://api.twitter.com/1/trends/current.json (http://api.twitter.com/1/trends/current.json)

and changed to a feed that can be limited by Yahoo! Where On Earth (http://http://developer.yahoo.com/geo/geoplanet/) region IDs. We want worldwide trending topics, so we set the region to 1:
http://api.twitter.com/1/trends/1.json (http://api.twitter.com/1/trends/1.json)

Additionally, there was a minor change in feed format that put the region into the trend results. This was fixed by modifying the search keys.

The update instructions are here, a .bat file is included in the firmware to save you some typing. Latest source is in SVN.
http://dangerousprototypes.com/docs/Net ... _procedure (http://dangerousprototypes.com/docs/Network_firmware_update_procedure)

Also available at google code: http://code.google.com/p/dangerous-prot ... rmware.zip (http://code.google.com/p/dangerous-prototypes-open-hardware/downloads/detail?name=twatchv2-v0f-firmware.zip)
Title: Re: Change to Twitter, Twatch no longer working?
Post by: dmoisan on November 16, 2011, 08:35:42 pm
I have it running here.  Though I'm not much into Twitter, it's an interesting application and I'm looking forward to reading your most recent source to get ideas for my own project.
Title: Re: Change to Twitter, Twatch no longer working?
Post by: babofish on January 31, 2013, 02:53:33 am
Just dug my #twatch out of a box and hooked it up, didn't work. I updated to the v0f firmware and it is still showing "*Error, waiting 5min" then it tries to reconnect and rolls back to the same message. The LCD is lit by default now so I know the firmware got applied. It has a valid IP and responds to ping.

 Did the api feed change again? Can someone work up a fix?
Title: Re: Change to Twitter, Twatch no longer working?
Post by: ian on January 31, 2013, 07:16:42 am
I am unaware of any changes. If anyone knows the cause I can try to update it.
Title: Re: Change to Twitter, Twatch no longer working?
Post by: babofish on January 31, 2013, 04:31:24 pm
If you are not aware of any changes perhaps the issue is on my end. I will do some testing tonight maybe my firewall is causing issues.

Thanks for the quick reply to this forums full of dusty posts.