Get your PCBs made

From DP

(Difference between revisions)
Jump to: navigation , search
(Polygon fill isolation)
(Updated timings)
 
(37 intermediate revisions not shown)
Line 1: Line 1:
-
Under construction: PCB making guide
+
[[image:GetPCBSMade.jpg|600px]]
==Overview==
==Overview==
-
There are many inexpensive PCB services around. Seeed Studio (our preferred) and ITead Studio make two-sided PCBs with the works starting at $1 per 5x5cm PCB. Both use the same prototyping PCB factory in Shenzhen China. Turnaround is fast, shipping starts at $3.
+
In the last few years many inexpensive PCB services have popped up. It used to be that buying PCBs in hobby quantities was expensive and filled with gotchas.
-
Others like DorkBotBox, BatchPCB, etc. pool up multiple orders and send them to the fab. Laen at DorkBotPBX offers purple PCBs that have been quite popular.
+
Now, places like [http://www.seeedstudio.com/depot/?products_id=835 Seeed Studio] will send your PCBs to the inexpensive prototyping factory in Shenzhen China, and ship them anywhere in the world at great prices. You get two-sided PCBs, with the works, starting at $1 per 5x5cm PCB. Turnaround is a few days, worldwide shipping starts at $3. It's a happy day for electronics hobbyists.
-
We wanted to write a tutorial on how to get your PCB manufactured using these cheap services from source Eagle files.
+
Others services like [http://dorkbotpdx.org/wiki/pcb_order DorkBotPDX] and [http://batchpcb.com/index.php/Products BatchPCB] pool multiple orders so the group benefits from bulk pricing. Enough people are using these services that turnaround is quite fast. DorkBotPDX offers signature purple PCBs that have become quite popular.
-
==Check for airwires==
+
Our goal is to help you get your Eagle PCB designs manufactured. We show our 'pre-flight' checks to help spot problems before ordering boards. See examples of errors like under etching, over etching, and misaligned vias.
 +
 
 +
==Check for air wires==
[[image:Eagle-zoomUnrouted.jpg|600px]]
[[image:Eagle-zoomUnrouted.jpg|600px]]
-
First check if all yore connections are on the board. To do this you'll need the zoom-unrouted script.
+
It's easy to miss a small break in a trace, and Eagle doesn't provide any flashing warning signs. The zoom-unrouted ULP script will zoom in on any broken traces and save you headaches later.
-
#Download the [http://www.cadsoftusa.com/cadsoft-downloads/file/zoom-unrouted zoom-unrouted.ulp]
+
#Download [http://www.cadsoftusa.com/cadsoft-downloads/file/zoom-unrouted zoom-unrouted.ulp]
-
#Run it. (File > Run... > zoom-unrouted.ulp)
+
#Run it: ''File > Run... > zoom-unrouted.ulp''
-
#Connect the air-wire, if any is found.
+
#Eagle will zoom in on any air wires
-
#Re-Run the script, and keep repeating until no air-wires are found.
+
#Add the missing traces if any are found
 +
#Run it again until no new air wires are found
==Polygon fill isolation==
==Polygon fill isolation==
-
[[image:Eagle-groundseepover.jpg|600px]]
+
[[image:Eagle-groundseepover2.jpg|250px]]
-
[http://www.sebastians-site.de Picture by Sebastian CC-BY-SA].
+
-
A common error on cheap PCBs is when the ground fill crosses to a trace. If you have filled polygons on your board, be sure to increase the isolation to at-least 12mils(16+ recommended). This is done by right clicking on a polygons edge and going to Properties > Isolate.
+
A common error is when the ground fill or ground plane is connected to a trace. This is a symptom of under-etching at the PCB factory, and it can be minimized by using a reasonable isolation distance.
 +
 
 +
If you use a ground plane or other filled polygons on your board, be sure to increase the isolation to at-least 12mils (16mils+ recommended, depending on manufacturer).
 +
#Right click on a polygon's edge
 +
#Go to: ''Properties > Isolate''
 +
#Set the value
 +
 
 +
[http://www.sebastians-site.de Picture by Sebastian CC-BY-SA].
==Design rule check==
==Design rule check==
 +
Make sure your design is within the specifications of the PCB service you use. Most hobbyist-friendly PCB services provide an Eagle design rule check file that can highlight anything that can't be reliably produced.
-
Before sending your files to be manufactured you have make sure your design is within the specifications of the PCB service you will be using. To help you with this, the associated PCB service provides Design Rule Check files for Eagle. Grab a design rule file from your prefered PCB maker:
+
These services all provide a DRC file that works in Eagle:
*[http://www.seeedstudio.com/depot/fusion-pcb-service-p-835.html Seeed Studio]  
*[http://www.seeedstudio.com/depot/fusion-pcb-service-p-835.html Seeed Studio]  
*[http://iteadstudio.com/store/index.php?main_page=product_info&cPath=19_20&products_id=495 ITead Studio]
*[http://iteadstudio.com/store/index.php?main_page=product_info&cPath=19_20&products_id=495 ITead Studio]
-
*[http://dorkbotpdx.org/wiki/pcb_order DorkBotPBX]
+
*[http://dorkbotpdx.org/wiki/pcb_order DorkBotPDX]
*[http://www.sparkfun.com/tutorials/115 BatchPCB]
*[http://www.sparkfun.com/tutorials/115 BatchPCB]
[[image:Eagle-DRC.jpg|600px]]
[[image:Eagle-DRC.jpg|600px]]
-
To run a DRC follow these steps:
+
Eagle processes the DRC file and evaluates the board automatically. To run a design rule check:
#Open your PCB layout in Eagle
#Open your PCB layout in Eagle
-
#Go to Tools > DRC... A DRC window will open from which you can load the manufacturers .dru file you previously downloaded. From this window you can also make adjustment to the various design specifications like minimum trace width (Sizes > Minimum Width), and trace clearance (Clearance). It is usually a good idea to increase these two settings a few mils if your board doesn't require absolute minimum the board house can produce.
+
#Go to ''Tools > DRC...''
-
#Once you've set it up just click (Check).
+
#A DRC window will open. Load the manufacturer's DRC file.  
 +
#Click ok to start the check
 +
 
 +
From the DRC window you can adjustment the various design specifications like minimum trace width, clearance, etc. If a board doesn't need the smallest stuff the factory can make, we increase these settings a few mils as a safety margin.
[[image:Eagle-DRC2.jpg|600px]]
[[image:Eagle-DRC2.jpg|600px]]
-
The DRC will scan your board and log all the errors on your board that go outside the scope of the specifications. By clicking on various log entries the portion of the board where they occur will be zoomed in, and the error in question highlighted. You go through them one by one. Once you've fixed all the errors you simply re-run the DRC again and check if everything is alright.
+
The DRC will scan your board and log all the areas that go outside the manufacturer's limits. Click on various log entries to highlight each problem on the PCB.
-
==Generate gerbers==
+
After fixing the errors, run the DRC again to see if everything passes. Rinse and repeat until the board passes the DRC.
-
Once you are sure your board is electrically sound, and that it falls within the manufacturing specifications of your PCB service you need to generate files that the manufacturer can use for production. These files are called Gerbers. To generate them PCB manufacturers provide a .CAM file.
+
==Generate gerbers==
-
Grab the CAM file for your preferred PCB maker:
+
Once your board is electrically sound, it's time to generate files that the manufacturer can use in production. Gerber formatted files, usually just called gerbers, are files any respectable PCB house can use to make boards.
 +
We'll generate them using a CAM file provided by the fab:
*[http://www.seeedstudio.com/depot/datasheet/Fusion%20eagle.zip Seeed Studio]
*[http://www.seeedstudio.com/depot/datasheet/Fusion%20eagle.zip Seeed Studio]
*[http://iteadstudio.com/store/images/produce/PCB/PCB%20prototype/ITeadstudio_CAM.rar ITead Studio]
*[http://iteadstudio.com/store/images/produce/PCB/PCB%20prototype/ITeadstudio_CAM.rar ITead Studio]
-
*[http://content.laen.org/pcb/LaenPCBOrder.cam DorkBotPBX]
+
*[http://content.laen.org/pcb/LaenPCBOrder.cam DorkBotPDX]
*[http://www.sparkfun.com/tutorial/Eagle-DFM/sfe-gerb274x.cam BatchPCB]
*[http://www.sparkfun.com/tutorial/Eagle-DFM/sfe-gerb274x.cam BatchPCB]
Line 59: Line 73:
-
Follow these steps to build gerber files:
+
Follow these steps to generate gerber files:
-
#Start the CAM processor (File > CAM Processor). A CAM Processor window will pop-up.
+
#Open our PCB files in Eagle
-
#Go to File > Open > Job... and point to the previously downloaded .cam file.
+
#Start the CAM processor: ''File > CAM Processor''
-
#Once it is loaded, just click on the process job button.
+
#A CAM Processor window will pop up
-
#The gerber files will be saved in the same directory your source Eagle files are.
+
#Go to: ''File > Open > Job...'' and select the CAM file
 +
#Click on the process job button
 +
The gerber files will be saved in the same directory your Eagle source files  
[[image:Eagle-CAM2.jpg|600px]]
[[image:Eagle-CAM2.jpg|600px]]
 +
Each gerber file represents a layer of the PCB. They're like a PDF for circuit boards, any manufacturer should be able to open the files and make the board if it is within their ability.
-
The generated files are representations of various layers the manufacturer requires for building PCBs. The files you need to manufacture your boards are:
 
{| class="wikitable" border="1"
{| class="wikitable" border="1"
|+ Gerber Files
|+ Gerber Files
! Extension !!Layer
! Extension !!Layer
|-
|-
-
|GTL||Top Copper
+
|GTO||Top Silkscreen (text)
|-
|-
-
|GTO||Top Silkscreen
+
|GTS||Top Soldermask (the 'green' stuff)
|-
|-
-
|GTS||Top Soldermask
+
|GTL||Top Copper (conducting layer)
|-
|-
|GBL||Bottom Copper
|GBL||Bottom Copper
-
|-
 
-
|GBO||Bottom Silkscreen
 
|-
|-
|GBS||Bottom Soldermask
|GBS||Bottom Soldermask
|-
|-
-
|TXT||Routing and Drill
+
|GBO||Bottom Silkscreen
 +
|-
 +
|TXT||Routing and Drill (the holes and slots)
|}
|}
 +
 +
These are the seven layers/files typically required to manufacturer PCBs.
==Preview gerbers==
==Preview gerbers==
-
 
+
Before you send the gerbers to the board house, preview the files and make sure they look reasonable. You'll need a Gerber viewer, here are some free ones:
-
Check the files before sending them to the PCB house. To view them you'll need a Gerber viewer. Here are some free ones:
+
*[http://www.viewplot.com/ ViewPlot] (Windows only)
*[http://www.viewplot.com/ ViewPlot] (Windows only)
 +
*[http://www.pentalogix.com/viewmate.php ViewMate] (Windows only)
*[http://gerbv.gpleda.org/index.html gerbv] (Linux and Windows)
*[http://gerbv.gpleda.org/index.html gerbv] (Linux and Windows)
-
*[http://www.pentalogix.com/viewmate.php ViewMate] (Windows only)
 
[[image:Eagle-Gerb.jpg|600px]]
[[image:Eagle-Gerb.jpg|600px]]
-
We use ViewPlot, and here is how to set it up to view your files.
+
We use ViewPlot. To view your files:
-
#Start it up.
+
#Start ViewPlot
-
#Go to File > Load Files, select the 7 above mentioned files, and click "Open".
+
#Go to ''File > Load Files''
-
#A window with a list of the files will pop-up, click "OK".
+
#Select the 7 gerber files (GTO, GTS, GTL, GBL, GBS, GBO, TXT) and click "Open"
-
#Another pop up screen will show up, here you need to select the "Leading zero suppression" radio button, and select "2 4", and then click OK.
+
#A window with a list of the files will pop-up, click "OK"
-
 
+
#On the next screen (shown above) select the "Leading zero suppression" radio button, ''then'' select "2 4". Click OK
-
You should get a similar image to the one below. From there you can scroll through the layers in the lower left corner drop down menu.
+
[[image:Eagle-Gerb2.jpg|600px]]
[[image:Eagle-Gerb2.jpg|600px]]
-
==Zip up the files==
+
You should see a version of your PCB with each layer displayed as a different color. Scroll through the layers using the lower left corner drop down menu.
-
Put it in an archive. We include a readme.txt with....
+
-
For Seeed Studio and Itead order the PCB online and email the files. BatchPCB has a web interface, DorkBotPCX has XXXXX.
+
Look for any errors that might have happened before or after generating the gerbers. [http://dangerousprototypes.com/2011/11/21/gerber-preview-software-and-usage-summary/ More common ones are]:
 +
 
 +
*Problems with the footprint, the solder pad is sometimes buried by mask.
 +
*Drills outside board or flipped.
 +
*CAM didn’t export expected silkscreen layers.
 +
*Evaluating not only whether a silkscreen is present, but if it’s legible (size, location, etc).
 +
*Quickly seeing whether all of the  vias on a board are tented or not.
 +
*One last doublecheck to make sure soldermask is on the correct side for the correct component (PCB’s that have components on both sides).
 +
 
 +
==Zip the files and submit them==
 +
Now the gerbers are ready to go to the board house. Each service has different requirements, but most involve zipping the files and emailing them to someone. Submit by email to Seeed Studio, Itead, and DorkBotPDX. Upload via web page at BatchPCB.
==Get your boards==
==Get your boards==
-
In our experience, services take about this long:
+
[http://dangerousprototypes.com/2012/02/13/how-long-does-it-take-to-get-your-pcbs/ In our experience], it takes about this long from order to your hands:
-
*Seeed Studio
+
*Seeed Studio, from 2 to 4 weeks
-
*ITead Studio
+
*ITead Studio, from 2 to 4 weeks
-
*DorkBotPBX
+
*DorkBotPDX, around 2 to 4 weeks
-
*BatchPCB
+
*BatchPCB, from 2 to 4 weeks
Seeed and ITead offer cheaper boards if you only test 50% of them. The tested boards will be wrapped in masking tape and/or marked on the side with a marker.
Seeed and ITead offer cheaper boards if you only test 50% of them. The tested boards will be wrapped in masking tape and/or marked on the side with a marker.
-
How to inspect the board, what to look for (via alignment, shorts, missing traces, etc, example images from the forum).
+
==Inspection==
 +
Before you build the first PCB, spend five minutes looking it over. E-tested PCBs will nearly always be good. If a PCB is untested then you '''absolutely must''' inspect the board, or risk a broken or shorted trace under a chip that you'll never be able to find.
 +
 
 +
Here are three common problems. Eliminate these and save hours and days of debugging headaches.
 +
===Shorts===
 +
[[image:pcb-image-short.jpg|250px]]
 +
 
 +
Under etching leaves extra copper that connects traces together.
 +
 
 +
Avoid this by:
 +
*Use larger traces and increase the distance between them
 +
*Check your board house production limits, avoid working with the smallest traces and spacing
 +
 
 +
===Broken traces===
 +
[[image:pcb-trace-break.jpg|250px]]
 +
 
 +
Over etching removes too much copper and breaks traces.
 +
 
 +
Avoid this by:
 +
*Use larger traces
 +
*Check your board house production limits, avoid working with the smallest traces
 +
 
 +
We need a picture of this, can you help?
 +
 
 +
Image source: [http://blog.greg.so/ Greeeg] CC BY-SA
 +
 
 +
===Misaligned vias===
 +
[[file:pcb-via-misaligned.jpg|250px]]
 +
 
 +
The hole that connects two layers is drilled outside the via. This might break the connection between layers, or connect a trace to another nearby trace. In this picture the via is misaligned, but didn't break the nearby trace because of adequate clearance.
 +
 
 +
Avoid this by:
 +
*Using larger vias and larger annular rings (the copper pad around the via hole)
 +
*Check your board house production limits, avoid working at the smallest sizes
 +
*Increase any [[Get_your_PCBs_made#Polygon_fill_isolation|ground plane isolation]] so slightly miss-drilled holes don't short the trace to ground
 +
 
 +
We need a picture of this, can you help?
 +
 
 +
==Conclusion==
 +
Good luck with your PCBs. Don’t forget to share your latest creations in the [http://dangerousprototypes.com/forum/viewforum.php?f=56 project log forum] and through [http://dangerousprototypes.com/contact the contact form].
[[Category: Tutorials]]
[[Category: Tutorials]]

Latest revision as of 21:04, 26 July 2012

GetPCBSMade.jpg

Contents

Overview

In the last few years many inexpensive PCB services have popped up. It used to be that buying PCBs in hobby quantities was expensive and filled with gotchas.

Now, places like Seeed Studio will send your PCBs to the inexpensive prototyping factory in Shenzhen China, and ship them anywhere in the world at great prices. You get two-sided PCBs, with the works, starting at $1 per 5x5cm PCB. Turnaround is a few days, worldwide shipping starts at $3. It's a happy day for electronics hobbyists.

Others services like DorkBotPDX and BatchPCB pool multiple orders so the group benefits from bulk pricing. Enough people are using these services that turnaround is quite fast. DorkBotPDX offers signature purple PCBs that have become quite popular.

Our goal is to help you get your Eagle PCB designs manufactured. We show our 'pre-flight' checks to help spot problems before ordering boards. See examples of errors like under etching, over etching, and misaligned vias.

Check for air wires

Eagle-zoomUnrouted.jpg

It's easy to miss a small break in a trace, and Eagle doesn't provide any flashing warning signs. The zoom-unrouted ULP script will zoom in on any broken traces and save you headaches later.

  1. Download zoom-unrouted.ulp
  2. Run it: File > Run... > zoom-unrouted.ulp
  3. Eagle will zoom in on any air wires
  4. Add the missing traces if any are found
  5. Run it again until no new air wires are found

Polygon fill isolation

Eagle-groundseepover2.jpg

A common error is when the ground fill or ground plane is connected to a trace. This is a symptom of under-etching at the PCB factory, and it can be minimized by using a reasonable isolation distance.

If you use a ground plane or other filled polygons on your board, be sure to increase the isolation to at-least 12mils (16mils+ recommended, depending on manufacturer).

  1. Right click on a polygon's edge
  2. Go to: Properties > Isolate
  3. Set the value

Picture by Sebastian CC-BY-SA.

Design rule check

Make sure your design is within the specifications of the PCB service you use. Most hobbyist-friendly PCB services provide an Eagle design rule check file that can highlight anything that can't be reliably produced.

These services all provide a DRC file that works in Eagle:

Eagle-DRC.jpg

Eagle processes the DRC file and evaluates the board automatically. To run a design rule check:

  1. Open your PCB layout in Eagle
  2. Go to Tools > DRC...
  3. A DRC window will open. Load the manufacturer's DRC file.
  4. Click ok to start the check

From the DRC window you can adjustment the various design specifications like minimum trace width, clearance, etc. If a board doesn't need the smallest stuff the factory can make, we increase these settings a few mils as a safety margin.

Eagle-DRC2.jpg

The DRC will scan your board and log all the areas that go outside the manufacturer's limits. Click on various log entries to highlight each problem on the PCB.

After fixing the errors, run the DRC again to see if everything passes. Rinse and repeat until the board passes the DRC.

Generate gerbers

Once your board is electrically sound, it's time to generate files that the manufacturer can use in production. Gerber formatted files, usually just called gerbers, are files any respectable PCB house can use to make boards.

We'll generate them using a CAM file provided by the fab:

Eagle-CAM.jpg


Follow these steps to generate gerber files:

  1. Open our PCB files in Eagle
  2. Start the CAM processor: File > CAM Processor
  3. A CAM Processor window will pop up
  4. Go to: File > Open > Job... and select the CAM file
  5. Click on the process job button

The gerber files will be saved in the same directory your Eagle source files

Eagle-CAM2.jpg

Each gerber file represents a layer of the PCB. They're like a PDF for circuit boards, any manufacturer should be able to open the files and make the board if it is within their ability.

Gerber Files
Extension Layer
GTOTop Silkscreen (text)
GTSTop Soldermask (the 'green' stuff)
GTLTop Copper (conducting layer)
GBLBottom Copper
GBSBottom Soldermask
GBOBottom Silkscreen
TXTRouting and Drill (the holes and slots)

These are the seven layers/files typically required to manufacturer PCBs.

Preview gerbers

Before you send the gerbers to the board house, preview the files and make sure they look reasonable. You'll need a Gerber viewer, here are some free ones:

Eagle-Gerb.jpg

We use ViewPlot. To view your files:

  1. Start ViewPlot
  2. Go to File > Load Files
  3. Select the 7 gerber files (GTO, GTS, GTL, GBL, GBS, GBO, TXT) and click "Open"
  4. A window with a list of the files will pop-up, click "OK"
  5. On the next screen (shown above) select the "Leading zero suppression" radio button, then select "2 4". Click OK

Eagle-Gerb2.jpg

You should see a version of your PCB with each layer displayed as a different color. Scroll through the layers using the lower left corner drop down menu.

Look for any errors that might have happened before or after generating the gerbers. More common ones are:

  • Problems with the footprint, the solder pad is sometimes buried by mask.
  • Drills outside board or flipped.
  • CAM didn’t export expected silkscreen layers.
  • Evaluating not only whether a silkscreen is present, but if it’s legible (size, location, etc).
  • Quickly seeing whether all of the vias on a board are tented or not.
  • One last doublecheck to make sure soldermask is on the correct side for the correct component (PCB’s that have components on both sides).

Zip the files and submit them

Now the gerbers are ready to go to the board house. Each service has different requirements, but most involve zipping the files and emailing them to someone. Submit by email to Seeed Studio, Itead, and DorkBotPDX. Upload via web page at BatchPCB.

Get your boards

In our experience, it takes about this long from order to your hands:

  • Seeed Studio, from 2 to 4 weeks
  • ITead Studio, from 2 to 4 weeks
  • DorkBotPDX, around 2 to 4 weeks
  • BatchPCB, from 2 to 4 weeks

Seeed and ITead offer cheaper boards if you only test 50% of them. The tested boards will be wrapped in masking tape and/or marked on the side with a marker.

Inspection

Before you build the first PCB, spend five minutes looking it over. E-tested PCBs will nearly always be good. If a PCB is untested then you absolutely must inspect the board, or risk a broken or shorted trace under a chip that you'll never be able to find.

Here are three common problems. Eliminate these and save hours and days of debugging headaches.

Shorts

250px

Under etching leaves extra copper that connects traces together.

Avoid this by:

  • Use larger traces and increase the distance between them
  • Check your board house production limits, avoid working with the smallest traces and spacing

Broken traces

Pcb-trace-break.jpg

Over etching removes too much copper and breaks traces.

Avoid this by:

  • Use larger traces
  • Check your board house production limits, avoid working with the smallest traces

We need a picture of this, can you help?

Image source: Greeeg CC BY-SA

Misaligned vias

Pcb-via-misaligned.jpg

The hole that connects two layers is drilled outside the via. This might break the connection between layers, or connect a trace to another nearby trace. In this picture the via is misaligned, but didn't break the nearby trace because of adequate clearance.

Avoid this by:

  • Using larger vias and larger annular rings (the copper pad around the via hole)
  • Check your board house production limits, avoid working at the smallest sizes
  • Increase any ground plane isolation so slightly miss-drilled holes don't short the trace to ground

We need a picture of this, can you help?

Conclusion

Good luck with your PCBs. Don’t forget to share your latest creations in the project log forum and through the contact form.