Get your PCBs made

From DP

(Difference between revisions)
Jump to: navigation , search
(Generate gerbers)
(Preview gerbers)
Line 105: Line 105:
==Preview gerbers==
==Preview gerbers==
-
 
+
Before you send the gerbers to the board house, preview the files and make sure they look reasonable. You'll need a Gerber viewer, here are some free ones:
-
Check the files before sending them to the PCB house. To view them you'll need a Gerber viewer. Here are some free ones:
+
*[http://www.viewplot.com/ ViewPlot] (Windows only)
*[http://www.viewplot.com/ ViewPlot] (Windows only)
 +
*[http://www.pentalogix.com/viewmate.php ViewMate] (Windows only)
*[http://gerbv.gpleda.org/index.html gerbv] (Linux and Windows)
*[http://gerbv.gpleda.org/index.html gerbv] (Linux and Windows)
-
*[http://www.pentalogix.com/viewmate.php ViewMate] (Windows only)
 
[[image:Eagle-Gerb.jpg|600px]]
[[image:Eagle-Gerb.jpg|600px]]
-
We use ViewPlot, and here is how to set it up to view your files.
+
We use ViewPlot. To view your files:
-
#Start it up.
+
#Start ViewPlot
-
#Go to File > Load Files, select the 7 above mentioned files, and click "Open".
+
#Go to ''File > Load Files''
-
#A window with a list of the files will pop-up, click "OK".
+
#Select the 7 gerber files (GTO, GTS, GTL, GBL, GBS, GBO, TXT) and click "Open"
-
#Another pop up screen will show up, here you need to select the "Leading zero suppression" radio button, and select "2 4", and then click OK.
+
#A window with a list of the files will pop-up, click "OK"
 +
#On the next screen (shown above) select the "Leading zero suppression" radio button, ''then'' select "2 4". Click OK
-
You should get a similar image to the one below. From there you can scroll through the layers in the lower left corner drop down menu.
+
[[image:Eagle-Gerb2.jpg|600px]]
-
[[image:Eagle-Gerb2.jpg|600px]]
+
You should a version of your PCB with each layer displayed as a different color. Scroll through the layers using the lower left corner drop down menu.
-
Look for any errors in the board you can spot. More common ones are:
+
Look for any errors that might have happened before or after generating the gerbers. [http://dangerousprototypes.com/2011/11/21/gerber-preview-software-and-usage-summary/ More common ones are]:
*Problems with the footprint, the solder pad is sometimes buried by mask.
*Problems with the footprint, the solder pad is sometimes buried by mask.
*Drills outside board or flipped.
*Drills outside board or flipped.
*CAM didn’t export expected silkscreen layers.
*CAM didn’t export expected silkscreen layers.
-
*Evaluating not only whether a silkscreen is present, but if it’s legable (size, location, etc).
+
*Evaluating not only whether a silkscreen is present, but if it’s legible (size, location, etc).
*Quickly seeing whether all of the  vias on a board are tented or not.
*Quickly seeing whether all of the  vias on a board are tented or not.
*One last doublecheck to make sure soldermask is on the correct side for the correct component (PCB’s that have components on both sides).
*One last doublecheck to make sure soldermask is on the correct side for the correct component (PCB’s that have components on both sides).

Revision as of 14:59, 14 February 2012

GetPCBSMade.jpg

Contents

Overview

In the last few years many inexpensive PCB services have popped up. It used to be that buying PCBs in hobby quantities was expensive and filled with gotchas.

Now, places like Seeed Studio can send your PCBs to the inexpensive prototyping factory in Shenzhen China, and ship them anywhere in the world at great prices. You get two-sided PCBs, with the works, starting at $1 per 5x5cm PCB. Turnaround is a few days, worldwide shipping starts at $3. It's a happy day for electronics hobbyists.

Others services like DorkBotPBX and BatchPCB pool multiple orders so the group benefits from bulk pricing. Enough people are using these services that turnaround is quite fast. DorkBotPBX offers signature purple PCBs that have become quite popular.

Our goal is to help you get your Eagle PCB designs manufactured. We show our 'pre-flight' checks to help spot problems before ordering boards. See examples of errors like under etching, over etching, and misaligned vias.

Check for air wires

Eagle-zoomUnrouted.jpg

It's easy to miss a small break in a trace, and Eagle doesn't provide any flashing warning signs. The zoom-unrouted ULP script will zoom in on any broken traces and save you headaches later.

  1. Download zoom-unrouted.ulp
  2. Run it: File > Run... > zoom-unrouted.ulp
  3. Eagle will zoom in on any air wires
  4. Add the missing traces if any are found
  5. Run it again until no new air wires are found

Polygon fill isolation

Eagle-groundseepover2.jpg

A common error is when the ground fill or ground plane is connected to a trace. This is a symptom of under-etching at the PCB factory, and it can be minimized by using a reasonable isolation distance.

If you use a ground plane or other filled polygons on your board, be sure to increase the isolation to at-least 12mils (16mils+ recommended, depending on manufacturer).

  1. Right click on a polygon's edge
  2. Go to: Properties > Isolate
  3. Set the value

Picture by Sebastian CC-BY-SA.

Design rule check

Make sure your design is within the specifications of the PCB service you use. Most hobbyist-friendly PCB services provide an Eagle design rule check file that can highlight anything that can't be reliably produced.

These services all provide a DRC file that works in Eagle:

Eagle-DRC.jpg

Eagle processes the DRC file and evaluates the board automatically. To run a design rule check:

  1. Open your PCB layout in Eagle
  2. Go to Tools > DRC...
  3. A DRC window will open. Load the manufacturer's DRC file.
  4. Click ok to start the check

From the DRC window you can adjustment the various design specifications like minimum trace width, clearance, etc. If a board doesn't need the smallest stuff the factory can make, we increase these settings a few mils as a safety margin.

Eagle-DRC2.jpg

The DRC will scan your board and log all the areas that go outside the manufacturer's limits. Click on various log entries to highlight each problem on the PCB.

After fixing the errors, run the DRC again to see if everything passes. Rinse and repeat until the board passes the DRC.

Generate gerbers

Once your board is electrically sound, it's time to generate files that the manufacturer can use in production. Gerber formatted files, usually just called gerbers, are files any respectable PCB house can use to make boards.

We'll generate them using a CAM file provided by the fab:

Eagle-CAM.jpg


Follow these steps to generate gerber files:

  1. Open our PCB files in Eagle
  2. Start the CAM processor: File > CAM Processor
  3. A CAM Processor window will pop up
  4. Go to: File > Open > Job... and select the CAM file
  5. Click on the process job button

The gerber files will be saved in the same directory your Eagle source files

Eagle-CAM2.jpg

Each gerber file represents a layer of the PCB. They're like a PDF for circuit boards, any manufacturer should be able to open the files and make the board if it is within their ability.

Gerber Files
Extension Layer
GTOTop Silkscreen (text)
GTSTop Soldermask (the 'green' stuff)
GTLTop Copper (conducting layer)
GBLBottom Copper
GBSBottom Soldermask
GBOBottom Silkscreen
TXTRouting and Drill (the holes and slots)

Preview gerbers

Before you send the gerbers to the board house, preview the files and make sure they look reasonable. You'll need a Gerber viewer, here are some free ones:

Eagle-Gerb.jpg

We use ViewPlot. To view your files:

  1. Start ViewPlot
  2. Go to File > Load Files
  3. Select the 7 gerber files (GTO, GTS, GTL, GBL, GBS, GBO, TXT) and click "Open"
  4. A window with a list of the files will pop-up, click "OK"
  5. On the next screen (shown above) select the "Leading zero suppression" radio button, then select "2 4". Click OK

Eagle-Gerb2.jpg

You should a version of your PCB with each layer displayed as a different color. Scroll through the layers using the lower left corner drop down menu.

Look for any errors that might have happened before or after generating the gerbers. More common ones are:

  • Problems with the footprint, the solder pad is sometimes buried by mask.
  • Drills outside board or flipped.
  • CAM didn’t export expected silkscreen layers.
  • Evaluating not only whether a silkscreen is present, but if it’s legible (size, location, etc).
  • Quickly seeing whether all of the vias on a board are tented or not.
  • One last doublecheck to make sure soldermask is on the correct side for the correct component (PCB’s that have components on both sides).

Zip up the files

Put it in an archive. We include a readme.txt with some basic information about the boards, here is an example.

"Name, email, service , PCB color, gerber format(2.4 leading)"

For Seeed Studio, Itead order the PCB online and email the files. BatchPCB has a web interface, while for DorkBotPCX you need to send them an email as described by their instructions.

Get your boards

In our experience, services take about this long from order to your hands:

  • Seeed Studio, from 2 to 4 weeks
  • ITead Studio, from 2 to 4 weeks
  • DorkBotPBX, around 2 weeks
  • BatchPCB, from 2 to 4 weeks

Seeed and ITead offer cheaper boards if you only test 50% of them. The tested boards will be wrapped in masking tape and/or marked on the side with a marker.

Inspection

Before you build the first PCB, spend five minutes looking it over. E-tested PCBs will nearly always be good. If a PCB is untested then you absolutely must inspect the board, or risk a broken or shorted trace under a chip that you'll never be able to find.

Here are three common problems that can cause hours and days of debugging headaches.

Shorts

250px

Under etching leaves extra copper that connects traces together.

Avoid this by:

  • Use larger traces and increase the distance between them
  • Check your board house production limits, avoid working with the smallest traces and spacing

Broken traces

Over etching removes too much copper and breaks traces.

Avoid this by:

  • Use larger traces
  • Check your board house production limits, avoid working with the smallest traces

We need a picture of this, can you help?

Misaligned vias

The hole that connects two layers can be drilled outside the via. This can break the connection between layers, or short a trace to another nearby trace.

Avoid this by:

  • Using larger vias and larger annular rings (the copper pad around the via hole)
  • Check your board house production limits, avoid working at the smallest sizes
  • Increase any ground plane isolation so slightly miss-drilled holes don't short the trace to ground

We need a picture of this, can you help?