Get your PCBs made

From DP

(Difference between revisions)
Jump to: navigation , search
(Polygon fill isolation)
(Polygon fill isolation)
Line 21: Line 21:
==Polygon fill isolation==
==Polygon fill isolation==
-
[[image:Eagle-groundseepover2.jpg|250px]]
+
[[image:Eagle-groundseepover2.jpg|600px]]
[http://www.sebastians-site.de Picture by Sebastian CC-BY-SA].
[http://www.sebastians-site.de Picture by Sebastian CC-BY-SA].

Revision as of 12:43, 14 February 2012

Under construction: PCB making guide

Contents

Overview

There are many inexpensive PCB services around. Seeed Studio (our preferred) and ITead Studio make two-sided PCBs with the works starting at $1 per 5x5cm PCB. Both use the same prototyping PCB factory in Shenzhen China. Turnaround is fast, shipping starts at $3.

Others like DorkBotBox, BatchPCB, etc. pool up multiple orders and send them to the fab. Laen at DorkBotPBX offers purple PCBs that have been quite popular.

We wanted to write a tutorial on how to get your PCB manufactured using these cheap services from source Eagle files.

Check for airwires

Eagle-zoomUnrouted.jpg

First check if all yore connections are on the board. To do this you'll need the zoom-unrouted script.

  1. Download the zoom-unrouted.ulp
  2. Run it. (File > Run... > zoom-unrouted.ulp)
  3. Connect the air-wire, if any is found.
  4. Re-Run the script, and keep repeating until no air-wires are found.

Polygon fill isolation

Eagle-groundseepover2.jpg

Picture by Sebastian CC-BY-SA.

A common error with cheap PCBs is when the ground fill crosses to a trace. If you have filled polygons on your board, be sure to increase the isolation to at-least 12mils(16+ recommended). This is done by right clicking on a polygon's edge and going to Properties > Isolate.

Design rule check

Before sending your files to be manufactured you have make sure your design is within the specifications of the PCB service you will be using. To help you with this, the associated PCB service provides Design Rule Check files for Eagle. Grab a design rule file from your prefered PCB maker:

Eagle-DRC.jpg

To run a DRC follow these steps:

  1. Open your PCB layout in Eagle
  2. Go to Tools > DRC... A DRC window will open from which you can load the manufacturers .dru file you previously downloaded. From this window you can also make adjustment to the various design specifications like minimum trace width (Sizes > Minimum Width), and trace clearance (Clearance). It is usually a good idea to increase these two settings a few mils if your board doesn't require absolute minimum the board house can produce.
  3. Once you've set it up just click (Check).

Eagle-DRC2.jpg

The DRC will scan your board and log all the errors on your board that go outside the scope of the specifications. By clicking on various log entries the portion of the board where they occur will be zoomed in, and the error in question highlighted. You go through them one by one. Once you've fixed all the errors you simply re-run the DRC again and check if everything is alright.

Generate gerbers

Once you are sure your board is electrically sound, and that it falls within the manufacturing specifications of your PCB service you need to generate files that the manufacturer can use for production. These files are called Gerbers. To generate them PCB manufacturers provide a .CAM file.

Grab the CAM file for your preferred PCB maker:

Eagle-CAM.jpg


Follow these steps to build gerber files:

  1. Start the CAM processor (File > CAM Processor). A CAM Processor window will pop-up.
  2. Go to File > Open > Job... and point to the previously downloaded .cam file.
  3. Once it is loaded, just click on the process job button.
  4. The gerber files will be saved in the same directory your source Eagle files are.

Eagle-CAM2.jpg


The generated files are representations of various layers the manufacturer requires for building PCBs. The files you need to manufacture your boards are:

Gerber Files
Extension Layer
GTLTop Copper
GTOTop Silkscreen
GTSTop Soldermask
GBLBottom Copper
GBOBottom Silkscreen
GBSBottom Soldermask
TXTRouting and Drill

Preview gerbers

Check the files before sending them to the PCB house. To view them you'll need a Gerber viewer. Here are some free ones:

Eagle-Gerb.jpg

We use ViewPlot, and here is how to set it up to view your files.

  1. Start it up.
  2. Go to File > Load Files, select the 7 above mentioned files, and click "Open".
  3. A window with a list of the files will pop-up, click "OK".
  4. Another pop up screen will show up, here you need to select the "Leading zero suppression" radio button, and select "2 4", and then click OK.

You should get a similar image to the one below. From there you can scroll through the layers in the lower left corner drop down menu.

Eagle-Gerb2.jpg

Look for any errors in the board you can spot. More common ones are:

  • Problems with the footprint, the solder pad is sometimes buried by mask.
  • Drills outside board or flipped.
  • CAM didn’t export expected silkscreen layers.
  • Evaluating not only whether a silkscreen is present, but if it’s legable (size, location, etc).
  • Quickly seeing whether all of the vias on a board are tented or not.
  • One last doublecheck to make sure soldermask is on the correct side for the correct component (PCB’s that have components on both sides).

Zip up the files

Put it in an archive. We include a readme.txt with....

For Seeed Studio and Itead order the PCB online and email the files. BatchPCB has a web interface, DorkBotPCX has XXXXX.

Get your boards

In our experience, services take about this long:

  • Seeed Studio
  • ITead Studio
  • DorkBotPBX
  • BatchPCB

Seeed and ITead offer cheaper boards if you only test 50% of them. The tested boards will be wrapped in masking tape and/or marked on the side with a marker.

Inspection

Before you build the first PCB, spend five minutes looking it over. E-tested PCBs will nearly always be good. If a PCB is untested then you absolutely must inspect the board, or risk a broken or shorted trace under a chip that you'll never be able to find.

Here are three common problems that can cause hours and days of debugging headaches.

Shorts

250px

Under etching leaves extra copper that connects traces together.

Avoid this by:

  • Use larger traces and increase the distance between them
  • Check your board house production limits, avoid working with the smallest traces and spacing

Broken traces

Over etching removes too much copper and breaks traces.

Avoid this by:

  • Use larger traces
  • Check your board house production limits, avoid working with the smallest traces

We need a picture of this, can you help?

Misaligned vias

The hole that connects two layers can be drilled outside the via. This can break the connection between layers, or short a trace to another nearby trace.

Avoid this by:

  • Using larger vias and larger annular rings (the copper pad around the via hole)
  • Check your board house production limits, avoid working at the smallest sizes
  • Increase any ground plane isolation so slightly miss-drilled holes don't short the trace to ground

We need a picture of this, can you help?