Get your PCBs made

From DP

Jump to: navigation , search




In the last few years many inexpensive PCB services have popped up. It used to be that buying PCBs in hobby quantities was expensive and filled with gotchas.

Now, places like Seeed Studio will send your PCBs to the inexpensive prototyping factory in Shenzhen China, and ship them anywhere in the world at great prices. You get two-sided PCBs, with the works, starting at $1 per 5x5cm PCB. Turnaround is a few days, worldwide shipping starts at $3. It's a happy day for electronics hobbyists.

Others services like DorkBotPDX and BatchPCB pool multiple orders so the group benefits from bulk pricing. Enough people are using these services that turnaround is quite fast. DorkBotPDX offers signature purple PCBs that have become quite popular.

Our goal is to help you get your Eagle PCB designs manufactured. We show our 'pre-flight' checks to help spot problems before ordering boards. See examples of errors like under etching, over etching, and misaligned vias.

Check for air wires


It's easy to miss a small break in a trace, and Eagle doesn't provide any flashing warning signs. The zoom-unrouted ULP script will zoom in on any broken traces and save you headaches later.

  1. Download zoom-unrouted.ulp
  2. Run it: File > Run... > zoom-unrouted.ulp
  3. Eagle will zoom in on any air wires
  4. Add the missing traces if any are found
  5. Run it again until no new air wires are found

Polygon fill isolation


A common error is when the ground fill or ground plane is connected to a trace. This is a symptom of under-etching at the PCB factory, and it can be minimized by using a reasonable isolation distance.

If you use a ground plane or other filled polygons on your board, be sure to increase the isolation to at-least 12mils (16mils+ recommended, depending on manufacturer).

  1. Right click on a polygon's edge
  2. Go to: Properties > Isolate
  3. Set the value

Picture by Sebastian CC-BY-SA.

Design rule check

Make sure your design is within the specifications of the PCB service you use. Most hobbyist-friendly PCB services provide an Eagle design rule check file that can highlight anything that can't be reliably produced.

These services all provide a DRC file that works in Eagle:


Eagle processes the DRC file and evaluates the board automatically. To run a design rule check:

  1. Open your PCB layout in Eagle
  2. Go to Tools > DRC...
  3. A DRC window will open. Load the manufacturer's DRC file.
  4. Click ok to start the check

From the DRC window you can adjustment the various design specifications like minimum trace width, clearance, etc. If a board doesn't need the smallest stuff the factory can make, we increase these settings a few mils as a safety margin.


The DRC will scan your board and log all the areas that go outside the manufacturer's limits. Click on various log entries to highlight each problem on the PCB.

After fixing the errors, run the DRC again to see if everything passes. Rinse and repeat until the board passes the DRC.

Generate gerbers

Once your board is electrically sound, it's time to generate files that the manufacturer can use in production. Gerber formatted files, usually just called gerbers, are files any respectable PCB house can use to make boards.

We'll generate them using a CAM file provided by the fab:


Follow these steps to generate gerber files:

  1. Open our PCB files in Eagle
  2. Start the CAM processor: File > CAM Processor
  3. A CAM Processor window will pop up
  4. Go to: File > Open > Job... and select the CAM file
  5. Click on the process job button

The gerber files will be saved in the same directory your Eagle source files


Each gerber file represents a layer of the PCB. They're like a PDF for circuit boards, any manufacturer should be able to open the files and make the board if it is within their ability.

Gerber Files
Extension Layer
GTOTop Silkscreen (text)
GTSTop Soldermask (the 'green' stuff)
GTLTop Copper (conducting layer)
GBLBottom Copper
GBSBottom Soldermask
GBOBottom Silkscreen
TXTRouting and Drill (the holes and slots)

These are the seven layers/files typically required to manufacturer PCBs.

Preview gerbers

Before you send the gerbers to the board house, preview the files and make sure they look reasonable. You'll need a Gerber viewer, here are some free ones:


We use ViewPlot. To view your files:

  1. Start ViewPlot
  2. Go to File > Load Files
  3. Select the 7 gerber files (GTO, GTS, GTL, GBL, GBS, GBO, TXT) and click "Open"
  4. A window with a list of the files will pop-up, click "OK"
  5. On the next screen (shown above) select the "Leading zero suppression" radio button, then select "2 4". Click OK


You should see a version of your PCB with each layer displayed as a different color. Scroll through the layers using the lower left corner drop down menu.

Look for any errors that might have happened before or after generating the gerbers. More common ones are:

  • Problems with the footprint, the solder pad is sometimes buried by mask.
  • Drills outside board or flipped.
  • CAM didn’t export expected silkscreen layers.
  • Evaluating not only whether a silkscreen is present, but if it’s legible (size, location, etc).
  • Quickly seeing whether all of the vias on a board are tented or not.
  • One last doublecheck to make sure soldermask is on the correct side for the correct component (PCB’s that have components on both sides).

Zip the files and submit them

Now the gerbers are ready to go to the board house. Each service has different requirements, but most involve zipping the files and emailing them to someone. Submit by email to Seeed Studio, Itead, and DorkBotPDX. Upload via web page at BatchPCB.

Get your boards

In our experience, it takes about this long from order to your hands:

  • Seeed Studio, from 2 to 4 weeks
  • ITead Studio, from 2 to 4 weeks
  • DorkBotPDX, around 2 to 4 weeks
  • BatchPCB, from 2 to 4 weeks

Seeed and ITead offer cheaper boards if you only test 50% of them. The tested boards will be wrapped in masking tape and/or marked on the side with a marker.


Before you build the first PCB, spend five minutes looking it over. E-tested PCBs will nearly always be good. If a PCB is untested then you absolutely must inspect the board, or risk a broken or shorted trace under a chip that you'll never be able to find.

Here are three common problems. Eliminate these and save hours and days of debugging headaches.



Under etching leaves extra copper that connects traces together.

Avoid this by:

  • Use larger traces and increase the distance between them
  • Check your board house production limits, avoid working with the smallest traces and spacing

Broken traces


Over etching removes too much copper and breaks traces.

Avoid this by:

  • Use larger traces
  • Check your board house production limits, avoid working with the smallest traces

We need a picture of this, can you help?

Image source: Greeeg CC BY-SA

Misaligned vias


The hole that connects two layers is drilled outside the via. This might break the connection between layers, or connect a trace to another nearby trace. In this picture the via is misaligned, but didn't break the nearby trace because of adequate clearance.

Avoid this by:

  • Using larger vias and larger annular rings (the copper pad around the via hole)
  • Check your board house production limits, avoid working at the smallest sizes
  • Increase any ground plane isolation so slightly miss-drilled holes don't short the trace to ground

We need a picture of this, can you help?


Good luck with your PCBs. Don’t forget to share your latest creations in the project log forum and through the contact form.