Announcing PyBOMBS GNU Radio installation tool

gnuradio-logo
The GNU Radio development team announces their new Python Build Overlay Managed Bundle System (PyBOMBS). If you’ve ever tried to install GNU Radio for use with the RTL-SDR or other software defined radio, you know it can be a hit or miss proposition. Depending on your OS and distro, it an be either flawless or dependency hell. Recognizing this situation the GNU Radio crew developed an installation tool which should make it easier to build GNU Radio and its dependencies, as well as to co-locate and build out-of-tree projects (gr-osmosdr, gr-baz, etc.) They intend to provide better integration with out-of-tree project through the use of build script known as “recipes”, that determines how to build and install a project, including dependencies, where to find the source code, and a template that tells the system how to build a type of project (cmake, autotools, etc.)

Give GNU Radio a try by installing with PyBOMBS today. (We just wouldn’t suggest discussing this new software tool in airports or on commercial airliners…)

This entry was posted in News, open source, SDR, software and tagged , .

Comments

  1. SYNTRONIKS says:

    Well gnuradio is an easy install on ubuntu really. It just takes a good while to complete. I wish it had good support for Wdoze but that may be asking too much. Really things went off without a hitch once I had the prereqs.

    Who else is waiting on a bladeRF? I am getting antsy!!!

  2. Layne says:

    I want my bladeRF, real bad!!!

  3. Alan says:

    bladeRF ? $420…
    I don’t have USB3 on my laptop…
    The signals that interest me are mostly HF – and even with an extra $120 for the Transverter, it can’t handle signals below 10MHz…

    I’ll pass, thank you.

  4. Drone says:

    At risk of cross-posting information, this DP Blog post:

    http://dangerousprototypes.com/2013/04/01/authoritative-gnu-radio-training-videos/

    Refers to to other Gnu Radio options:

    A Pentoo Linux live CD.

    A live USB from Ettus Research.

    That said, I wonder if this new Python based install script thingy from Gnu Radio will help get the latest Gnu Radio application running on a Raspberry Pi running Raspian?

    I’ve looked at this thread about Gnu Radio on the Raspberry Pi, which doesn’t bode well:

    http://www.raspberrypi.org/phpBB3/viewtopic.php?f=63&t=21721

    Hmmm…

Leave a Comment

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Notify me of followup comments via e-mail. You can also subscribe without commenting.