Categories

Bus Pirate firmware v6.1 now available

Posted on Wednesday, January 11th, 2012 in Bus Pirate, firmware by DP

Bus Pirate firmware v6.1 is now available for download. This version fixes a big bug with the SUMP logic analyzer mode, and includes other small updates for hardware v3 and v4.

Bus Pirate firmware v6.1 changelog:

  • Fixed broken SUMP logic analyzer mode
  • Detect v3a/v3b/v3.5/eBay version in v3 hardware
  • Verified v4 firmware detect chip revision
  • Verified v4 has no 8 and 48 byte USB stack errors
  • UART autobaud detect improvements, make the ‘Nearest Common Baud’ function smarter (v4) Thanks Brent!
  • Verified UART autobaud to macro (v4)
  • Trimmed the autobaud text a little for size (v4)
  • Bus Pirate bitbang mode IO fix. Thanks tes! (v4)
  • Verified the USB led (v4)
  • Moved SVN completely to Dangerous Prototypes hardware SVN

Get your own handy Bus Pirate for $30, including world-wide shipping. Also available from our friendly distributors.

This entry was posted on Wednesday, January 11th, 2012 at 2:00 pm and is filed under Bus Pirate, firmware. You can follow any responses to this entry through the RSS 2.0 feed. You can skip to the end and leave a response. Pinging is currently not allowed.

12 Responses to “Bus Pirate firmware v6.1 now available”

  1. Mike Tsao says:

    Successful update on BP4! Had to build loader for Darwin.

  2. Jim Narem says:

    The V3 firmware file has a typo in the file name:
    BPv3-firmware/BPv3-frimware-v6.1.hex

    It installs fine (on a sparkfun BP).

  3. Marek Szuba says:

    Looks like you have forgotten to include extra BPv3 firmware in this version too, Ian.

  4. Dmitry says:

    Sorry to say that, but people hate tarbombs.

  5. James Newton says:

    Apparently removed from 6.1:
    – BASIC Script Engine
    – Alternate “extra” mode firmware (DIO, JTAG, PC Keyboard, etc…) is not available in the .zip.

    Anything else missing? And where do I find 5.9 if I happen to need one of those?

  6. Bruce says:

    Hey! There’s a minor off-by-one error in the source.

    in pirate-loader-source/source/pirate-loader.c, line 712
    replug the devide and try again
    "devide" should be "device"

  7. Mikkel says:

    Hi even after flashing the extras 5.9 i still have no jtag option in “m”.. Does it matter witch firmware was flashed before i flash the extras? I have a buspirate 3.6 withc atm has bootloader 4 and firmware 6.1.

    Does anyone have a similar experience.. jtag missing?

Leave a Reply

Notify me of followup comments via e-mail. You can also subscribe without commenting.

Recent Comments

  • Paul Campbell: I'm old enough that I started programming with punched cards .... each card had a sequence number in the last few characters. A friend once...
  • Ian: test comment on /blog/ page
  • ian: No, that's exactly how it should be :) Sorry about missing names on comments, the theme is being reworked as we speak.
  • J. Peterson: Nice writeup. It looks like some of the formatting for your command examples needs some missing newlines?
  • Geert Jordaens: I'm not sure what kind of licensing I have to add since it is a fairly straight forward implementation of the adaptive Huffman Decoding. For...